Labb 14: DHCPv4 och Relay server

I denna laboration kommer du att bygga och konfigurera ett nätverk som använder flera VLAN, inter-VLAN-routing och PVST (Per VLAN Spanning Tree) i en triangel-topologi. Nätverket består av två routrar (ROS1 och ROS2) som är anslutna till varandra samt till en ISP-router för att möjliggöra internet-åtkomst och centraliserad DHCP-hantering. Flera switchar kommer att användas för att konfigurera olika VLAN, där varje VLAN tilldelas ett specifikt IP-subnät för att effektivt hantera och optimera nätverkstrafikens flöde.

Bakgrund

Diginto har blivit tilldelad nätverksadressen 172.33.0.0/20, vilket innebär att du har totalt 4096 adresser att arbeta med. Din uppgift är att dela upp och segmentera detta nätverk för att stödja flera separata VLAN som representerar olika avdelningar inom organisationen.

Nätverksadresserna för de olika VLAN-segmenten tilldelas baserat på VLSM (Variable Length Subnet Mask) för att optimera användningen av adresser. Tilldelningen är som följer:

  • VLAN 10 Students: 2000 HA
  • VLAN 20 Staff: 1000 HA
  • VLAN 30 Teachers: 500 HA
  • VLAN 40 Administrators: 200 HA

Totalt behövs 3700 adresser för värdar över samtliga VLAN.

Topologi

Genomförande

VLAN 10 (2000 host-adresser)

  • 2x - 2 ≥ 2000; x = 11; 211 - 2 > 2000; 2048 - 2 > 2000; 2046 > 2000; 2046 HA
  • 32 - 11 = 21 då prefix = /21 = 255.255.248.0
  • Från /20 till /21 innebär 1 bit till då 21 = 2 NA
  • Segmenteringssteg = N.N.nnnn nhhh.H = 8
  • 172.33.0.0 /21 ger HA-interval: 172.33.0.1 till 172.33.7.254. Tilldelas till VLAN 10
  • 172.33.8.0 /21 segmenteras vidare

VLAN 20 (1000 host-adresser)

  • 2x - 2 ≥ 1000; x = 10; 210 - 2 > 1000; 1024 - 2 > 1000; 1022 HA
  • 32 - 10 = 22 då prefix = /22 = 255.255.252.0
  • Från /21 till /22 innebär 1 bit till då 21 = 2 NA
  • Segmenteringssteg = N.N.nnnn nnhh.H = 4
  • 172.33.8.0 /22 ger HA-intervall: 172.33.8.1 till 172.33.11.254. Tilldelas till VLAN 20
  • 172.33.12.0 /22 segmenteras vidare

VLAN 30 (500 host-adresser)

  • 2x - 2 ≥ 500; x = 9; 29 - 2 > 1000; 512 - 2 > 500; 510 HA
  • 32 - 9 = 23 då prefix = /23 = 255.255.254.0
  • Från /22 till /23 innebär 1 bit till då 21 = 2 NA
  • Segmenteringssteg = N.N.nnnn nnnh.H = 2
  • 172.33.12.0 /23 ger HA-intervall: 172.33.12.1 till 172.33.13.254. Tilldelas till VLAN 30
  • 172.33.14.0 /23 segmenteras vidare

VLAN 40 (200 host-adresser)

  • 2x - 2 ≥ 200; x = 8; 28 - 2 > 200; 256 - 2 > 200; 254 HA
  • 32 - 8 = 24 då prefix = /24 = 255.255.255.0
  • Från /23 till /24 innebär 1 bit till då 21 = 2 NA
  • Segmenteringssteg = N.N.nnnn nnnn.H = 1
  • 172.33.14.0 /24 ger HA-intervall: 172.33.14.1 till 172.33.14.254. Tilldelas till VLAN 40
  • 172.33.15.0 /22 Reserverat för framtida användning.

Tilldelningen är som följer:

  • VLAN 10 (2000 host-adresser): 172.33.0.0/21
  • VLAN 20 (1000 host-adresser): 172.33.8.0/22
  • VLAN 30 (500 host-adresser): 172.33.12.0/23
  • VLAN 40 (200 host-adresser): 172.33.14.0/24

Dessutom WAN-länkar är:

  • ROS1 till ISP 209.65.1.0/30
  • ROS2 till ISP 209.65.2.0/30
  • ROS3 till ROS2 209.65.3.0/30

Grundläggande konfiguration av ROS 1

  • ROS1(config)# interface s2/0
  • ROS1(config-if)# description DCE Connected to ISP
  • ROS1(config-if)# clock rate 2000000
  • ROS1(config-if)# ip address 209.65.1.1 255.255.255.252
  • ROS1(config-if)# no shutdown
  • ROS1(config-if)# interface s4/0
  • ROS1(config-if)# description DCE Connected to ROS2
  • ROS1(config-if)# clock rate 2000000
  • ROS1(config-if)# ip address 209.65.3.1 255.255.255.252
  • ROS1(config-if)# no shutdown
  • ROS1(config-if)# exit
  • ROS1(config)#

Grundläggande konfiguration av ISP

  • ISP(config)# interface s2/0
  • ISP(config-if)# description Connected to ROS1
  • ISP(config-if)# ip address 209.65.1.2 255.255.255.252
  • ISP(config-if)# no shutdown
  • ISP(config-if)# interface s4/0
  • ISP(config-if)# description Connected to ROS2
  • ISP(config-if)# ip address 209.65.2.1 255.255.255.252
  • ISP(config-if)# no shutdown
  • ISP(config-if)# exit
  • ISP(config)#

Grundläggande konfiguration av ROS 2

  • ROS2(config)# interface s3/0
  • ROS2(config-if)# description DCE Connected to ISP
  • ROS2(config-if)# clock rate 2000000
  • ROS2(config-if)# ip address 209.65.2.2 255.255.255.252
  • ROS2(config-if)# no shutdown
  • ROS2(config-if)# interface s4/0
  • ROS2(config-if)# description Connected to ROS1
  • ROS2(config-if)# ip address 209.65.3.2 255.255.255.252
  • ROS2(config-if)# no shutdown
  • ROS2(config-if)# exit
  • ROS2(config)#

Inter-VLAN konfigurationer på ROS1

  • ROS1(config)# interface g0/0
  • ROS1(config-if)# no ip address
  • ROS1(config-if)# shutdown
  • ROS1(config-if)# exit
  • ROS1(config)# interface g0/0.10
  • ROS1(config-subif)# encapsulation dot1Q 10
  • ROS1(config-subif)# ip address 172.33.0.1 255.255.248.0
  • ROS1(config-subif)# ip helper-address 209.65.1.2
  • ROS1(config-subif)# no shutdown
  • ROS1(config-subif)# exit
  • ROS1(config)# interface g0/0.20
  • ROS1(config-subif)# encapsulation dot1Q 20
  • ROS1(config-subif)# ip address 172.33.8.1 255.255.252.0
  • ROS1(config-subif)# ip helper-address 209.65.1.2
  • ROS1(config-subif)# no shutdown
  • ROS1(config-subif)# exit
  • ROS1(config)# interface g0/0
  • ROS1(config-if)# no shutdown
  • ROS1(config-if)# end
  • ROS1# copy running-config startup-config

Inter-VLAN konfigurationer på ROS2

  • ROS2(config)# interface g0/0
  • ROS2(config-if)# no ip address
  • ROS2(config-if)# shutdown
  • ROS2(config-if)# exit
  • ROS2(config)# interface g0/0.30
  • ROS2(config-subif)# encapsulation dot1Q 30
  • ROS2(config-subif)# ip address 172.33.12.1 255.255.254.0
  • ROS2(config-subif)# ip helper-address 209.65.2.1
  • ROS2(config-subif)# no shutdown
  • ROS2(config-subif)# exit
  • ROS2(config)# interface g0/0.40
  • ROS2(config-subif)# encapsulation dot1Q 40
  • ROS2(config-subif)# ip address 172.33.14.1 255.255.255.0
  • ROS2(config-subif)# ip helper-address 209.65.2.1
  • ROS2(config-subif)# no shutdown
  • ROS2(config-subif)# exit
  • ROS2(config)# interface g0/0
  • ROS2(config-if)# no shutdown
  • ROS2(config-if)# end
  • ROS2# copy running-config startup-config

Konfiguration av DHCP server

  • VLAN Students
  • ISP(config)# ip dhcp pool STUDENTS
  • ISP(dhcp-config)# network 172.33.0.0 255.255.248.0
  • ISP(dhcp-config)# default-router 172.33.0.1
  • ISP(dhcp-config)# domain-name diginto.se
  • ISP(dhcp-config)# dns-server 8.8.8.8
  • ISP(dhcp-config)# exit
  • ISP(config)#
  • VLAN Staff
  • ISP(config)# ip dhcp pool STAFF
  • ISP(dhcp-config)# network 172.33.8.0 255.255.252.0
  • ISP(dhcp-config)# default-router 172.33.8.1
  • ISP(dhcp-config)# domain-name diginto.se
  • ISP(dhcp-config)# dns-server 8.8.8.8
  • ISP(dhcp-config)# exit
  • ISP(config)#
  • VLAN Teachers
  • ISP(config)# ip dhcp pool TEACHERS
  • ISP(dhcp-config)# network 172.33.12.0 255.255.254.0
  • ISP(dhcp-config)# default-router 172.33.12.1
  • ISP(dhcp-config)# domain-name diginto.se
  • ISP(dhcp-config)# dns-server 8.8.8.8
  • ISP(dhcp-config)# exit
  • ISP(config)#
  • VLAN Administrators
  • ISP(config)# ip dhcp pool ADMINISTRATORS
  • ISP(dhcp-config)# network 172.33.14.0 255.255.255.0
  • ISP(dhcp-config)# default-router 172.33.14.1
  • ISP(dhcp-config)# domain-name diginto.se
  • ISP(dhcp-config)# dns-server 8.8.8.8
  • ISP(dhcp-config)# end
  • ISP# show ip dhcp pool
  • ISP# copy running-config startup-config

 

Konfiguration av SD1

  • SD1(config)# vlan 10
  • SD1(config-vlan)# name Students
  • SD1(config-vlan)# vlan 20
  • SD1(config-vlan)# name Staff
  • SD1(config-vlan)# exit
  • SD1(config)# vtp server
  • SD1(config)# vtp domain diginto
  • SD1(config)# vtp password digP@55
  • SD1(config)# interface range g0/1, g1/1, g2/1
  • SD1(config-if-range)# switchport mode trunk
  • SD1(config-if)# end
  • SD1# show interface trunk
  • SD1# copy running-config startup-config

Konfiguration av SD2

  • SD2(config)# vlan 30
  • SD2(config-vlan)# name Teachers
  • SD2(config-vlan)# vlan 40
  • SD2(config-vlan)# name Administrators
  • SD2(config-vlan)# exit
  • SD2(config)# vtp server
  • SD2(config)# vtp domain ng
  • SD2(config)# vtp password ngyP@55
  • SD2(config)# interface range g0/1, g1/1, g2/1
  • SD2(config-if-range)# switchport mode trunk
  • SD2(config-if)# end
  • SD2# show interface trunk
  • SD2# copy running-config startup-config

Konfiguration av SW1

  • VTP konfiguration
  • SW1(config)# vtp mode client
  • SW1(config)# vtp domain diginto
  • SW1(config)# vtp password digP@55
  • ! Vänta ett par sekunder och därefter verifiera vlan överföring från SD1
  • SW1(config)# do show vlan brief
  • ! Port tilldelning
  • SW1(config)# interface fa0/1
  • SW1(config-if)# switchport mode access
  • SW1(config-if)# switchport access vlan 10
  • SW1(config-if)# exit
  • SW1(config)# interface fa0/5
  • SW1(config-if)# switchport mode access
  • SW1(config-if)# switchport access vlan 20
  • SW1(config-if)# exit
  • ! STP konfiguration VLAN 10 primary
  • SW1(config)# spanning-tree vlan 10 root primary
  • ! Trunk konfiguration
  • SW1(config)# interface range g0/1-2
  • SW1(config-if-range)# switchport mode trunk
  • SW1(config-if-range)# end
  • ! Verifiering
  • SW1# show vlan brief
  • SW1# show interface trunk
  • SW1# show interface fa0/1 switchport
  • SW1# show interface fa0/5 switchport
  • SW1# copy running-config startup-config

Konfiguration av SW2

  • SW2(config)# vtp mode client
  • SW2(config)# vtp domain diginto
  • SW2(config)# vtp password digP@55
  • ! Vänta ett par sekunder och därefter verifiera vlan överföring från SD1
  • SW2(config)# do show vlan brief
  • ! Port tilldelning
  • SW2(config)# interface fa0/1
  • SW2(config-if)# switchport mode access
  • SW2(config-if)# switchport access vlan 10
  • SW2(config-if)# exit
  • SW2(config)# interface fa0/5
  • SW2(config-if)# switchport mode access
  • SW2(config-if)# switchport access vlan 20
  • SW2(config-if)# exit
  • ! STP konfiguration VLAN 20 primary
  • SW2(config)# spanning-tree vlan 20 root primary
  • ! Trunk konfiguration
  • SW2(config)# interface range g0/1-2
  • SW2(config-if-range)# switchport mode trunk
  • SW2(config-if-range)# end
  • ! Verifiering
  • SW2# show vlan brief
  • SW2# show interface trunk
  • SW2# show interface fa0/1 switchport
  • SW2# show interface fa0/5 switchport
  • SW2# copy running-config startup-config

Konfiguration av SW3

  • VTP konfiguration
  • SW3(config)# vtp mode client
  • SW3(config)# vtp domain ng
  • SW3(config)# vtp password ngyP@55
  • ! Vänta ett par sekunder och därefter verifiera vlan överföring från SD2
  • SW3(config)# do show vlan brief
  • ! Port tilldelning
  • SW3(config)# interface fa0/1
  • SW3(config-if)# switchport mode access
  • SW3(config-if)# switchport access vlan 30
  • SW3(config-if)# exit
  • SW3(config)# interface fa0/5
  • SW3(config-if)# switchport mode access
  • SW3(config-if)# switchport access vlan 40
  • SW3(config-if)# exit
  • ! STP konfiguration VLAN 30 primary
  • SW3(config)# spanning-tree vlan 30 root primary
  • ! Trunk konfiguration
  • SW3(config)# interface range g0/1-2
  • SW3(config-if-range)# switchport mode trunk
  • SW3(config-if-range)# end
  • ! Verifiering
  • SW3# show vlan brief
  • SW3# show interface trunk
  • SW3# show interface fa0/1 switchport
  • SW3# show interface fa0/5 switchport
  • SW3# copy running-config startup-config

Konfiguration av SW4

  • SW4(config)# vtp mode client
  • SW4(config)# vtp domain ng
  • SW4(config)# vtp password ngyP@55
  • ! Vänta ett par sekunder och därefter verifiera vlan överföring från SD1
  • SW4(config)# do show vlan brief
  • ! Port tilldelning
  • SW4(config)# interface fa0/1
  • SW4(config-if)# switchport mode access
  • SW4(config-if)# switchport access vlan 30
  • SW4(config-if)# exit
  • SW4(config)# interface fa0/5
  • SW4(config-if)# switchport mode access
  • SW4(config-if)# switchport access vlan 40
  • SW4(config-if)# exit
  • ! ST4 konfiguration VLAN 40 primary
  • SW4(config)# spanning-tree vlan 40 root primary
  • ! Trunk konfiguration
  • SW4(config)# interface range g0/1-2
  • SW4(config-if-range)# switchport mode trunk
  • SW4(config-if-range)# end
  • ! Verifiering
  • SW4# show vlan brief
  • SW4# show interface trunk
  • SW4# show interface fa0/1 switchport
  • SW4# show interface fa0/5 switchport
  • SW4# copy running-config startup-config