Static summary route

Vi börjar med “Static summary route“. En sådan route aggregerar flera nätverksadresser till en. Här nedan ett exempel:

Bild 1: Static Summary Route

i exemplet aggregeras följande nätverksadressen:

  • 172.20.0.0/16 (255.255.0.0)
  • 172.21.0.0/16 (255.255.0.0)
  • 172.22.0.0/16 (255.255.0.0)
  • 172.23.0.0/16 (255.255.0.0)

Metoden är att jämföra nätverksadresserna med varandra och söka efter skillnader per bit. Det kräver att nätverksadresserna skrivs i binärt format:

  • 1010 1100. 0001 0100.0000 000.0000 0000
  • 1010 1100. 0001 0101.0000 000.0000 0000
  • 1010 1100. 0001 0110.0000 000.0000 0000
  • 1010 1100. 0001 0111.0000 000.0000 0000

Lika bitar i nätverksadresserna har markerats med gult, de är 14 stycken. Resterande bitar nollställs:

  • 1010 1100. 0001 0100.0000 000.0000 0000
  • 1010 1100. 0001 0100.0000 000.0000 0000
  • 1010 1100. 0001 0100.0000 000.0000 0000
  • 1010 1100. 0001 0100.0000 000.0000 0000

Nu har alla nätverksadresser aggregerats till en och prefixet är 14!

  • 10101100.00010100.00000000.00000000 = 172.20.0.0/14

Konfigurationer

  • Router> enable
  • Router# configure terminal
  • Router(config)# hostname R1
  • R1(config)# interface s0/0/0
  • R1(config-if)# ip address 172.19.0.2 255.255.0.0
  • R1(config-if)# clock rate 128000
  • R1(config-if)# no shut
  • R1(config-if)# exit
  • Standard static route
  • R1(config)# ip route 172.20.0.0 255.252.0.0 172.19.0.1
  • Router> enable
  • Router# configure terminal
  • Router(config)# hostname R2
  • R2(config)# interface s0/0/1
  • R2(config-if)# ip address 172.19.0.1 255.255.255.252
  • R2(config-if)# no shut
  • R2(config-if)# exit
  • R2(config)# interface Gig0/0
  • R2(config-if)# ip address 172.20.0.1 255.255.0.0
  • R2(config-if)# no shut
  • R2(config-if)# exit
  • R2(config)# interface Gig0/1
  • R2(config-if)# ip address 172.22.0.1 255.255.0.0
  • R2(config-if)# no shut
  • R2(config-if)# exit
  • Standard static route
  • R2(config)# ip route 172.21.0.0 255.255.0.0 172.20.0.2
  • R2(config)# ip route 172.23.0.0 255.255.0.0 172.22.0.2
  • Default static route
  • R2(config)# ip route 0.0.0.0 0.0.0.0 172.19.0.2
  • Router> enable
  • Router# configure terminal
  • Router(config)# hostname R3
  • R3(config)# interface Gig0/0
  • R3(config-if)# ip address 172.20.0.2 255.255.0.0
  • R3(config-if)# no shut
  • R3(config-if)# exit
  • R3(config)# interface lo01
  • R3(config-if)# ip address 172.21.0.1 255.255.0.0
  • R3(config-if)# exit
  • Default static route
  • R3(config)# ip route 0.0.0.0 0.0.0.0 172.20.0.1
  • Router> enable
  • Router# configure terminal
  • Router(config)# hostname R4
  • R4(config)# interface Gig0/1
  • R4(config-if)# ip address 172.22.0.2 255.255.0.0
  • R4(config-if)# no shut
  • R4(config-if)# exit
  • R4(config-if)# interface lo01
  • R4(config-if)# ip address 172.23.0.1 255.255.0.0
  • R4(config-if)# exit
  • Default static route
  • R4(config)# ip route 0.0.0.0 0.0.0.0 172.22.0.1
  • R1# ping 172.21.0.1
  • R1# ping 172.23.0.1