IPv4 interface

En av flera skillnader mellan switchar och routrar är deras interface, till exempel switchar har flera FastEthernet eller Gigabit Ethernet portar än routrar. Switchar används inom lokala nätverk. Routrar stödjer LAN och WAN anslutningar och kan sammanbinda olika nätverksteknologier eller olika nätverkstyper. En routers port placeras i moduler som har en plats på router med namn SLOT.

Bild 1: Inte alltid samma ordning men oftast

Slots ger möjlighet att ha olika moduler med respektive portar, exempelvis router G2 ISR har två integrerade Gigabit Ethernet interface i en modul och två High-Speed WAN interface (HWIC) i en annan modul. Dessa moduler placeras i olika slot som organiseras oftast i en viss ordning, men ordningen kan variera modell till modell.

IPv4 router interface

Routers Ethernet interface används som default gateway för olika LAN. Härnedan olika Ethernet interface:

  • Ethernet – 10 Mbps, kan betecknas som e0, e1 och så vidare
  • FastEthernet – 100 Mbps, kan betecknas som Fa0/0, Fa0/1
  • GigabitEthernet – 1000 Mbps, kan betecknas som Ge0/1, Ge0/2 eller G0/0, G0/1
Bild 2: Routers Ethernet interface

Varje gång ett interface konfigureras ska interfacet aktiveras med kommandot: no shutdown

Här nedan en översikt på nödvändiga kommando:

Basic Router Interface Configuration 
Global konfigurationsläge Router>enable
Router#configure terminal
Configuring an interface Router(config)# interface type number
Router(config-if)# ip address address mask
Router(config-if)#description description
Router(config-if)# no shutdown
Saving changes on a router Router# copy running-config  startup-config
Examining the output of show commands Router# show running-config
Router# show ip route
Router# show ip interface brief
Router# show interfaces

Studera en stund topologin i bilden nedan:

Bild 3: Interface-konfigurationer

Bilden ovan illustrerar flera LAN anslutna via ett WAN-nätverk. Till vänster finns LAN1 och LAN 2 som ansluts till LAN3 och LAN4 via en WAN-länk mellan routrarna R1 och R2. Här nedan visas exempel på konfigurationer av alla LAN och WAN-interface. Beroende på typen av WAN-interface kan ytterligare konfigurationer vara nödvändiga exempelvis med seriella länkar mellan två routrar krävs en DCE och en DTE. Den ena router ska konfigureras som DCE med kommandot clock rate <hastighet> så att den kan styra arbetstakten genom att synkronisera kommunikationen med den andra router. Just den andra routern behöver inte konfigureras eftersom som default är alla routrar DTE.

Konfigurationer inkluderar också IP-adressering för switcharna med syfte att kunna komma åt de via Telnet eller SSH.

Konfigurationer

  • Router R1 grundkonfiguration
  • Router> enable
  • Router# configure terminal
  • Router(config)# hostname R1
  • R1(config)#
  • R1 interface g0/0 konfiguration
  • R1(config)# interface gigabitEthernet 0/0
  • R1(config-if)# description Link to LAN 1
  • R1(config-if)# ip address 192.168.10.1 255.255.255.0
  • R1(config-if)# no shutdown
  • R1(config-if)#exit
  • Switch sw-lan1 grundkonfiguration
  • Switch> enable
  • Switch# configure terminal
  • Switch(config)# hostname sw-lan1
  • sw-lan1(config)#
  • sw-lan1(config)# interface vlan 1
  • sw-lan1(config-if)# ip address  192.168.10.2  255.255.255.0
  • sw-lan1(config-if)# no shutdown
  • sw-lan1(config-if)# exit
  • sw-lan1(config)# default-gateway 192.168.10.1
  • sw-lan1(config)# end
  • sw-lan1#
  • R1 interface g0/1 konfiguration
  • R1(config)# interface gigabitEthernet 0/1
  • R1(config-if)# description Link to LAN 2
  • R1(config-if)# ip address 192.168.11.1 255.255.255.0
  • R1(config-if)# no shutdown
  • R1(config-if)#exit
  • Switch sw-lan2 grundkonfiguration
  • Switch> enable
  • Switch# configure terminal
  • Switch(config)# hostname sw-lan2
  • sw-lan2(config)#
  • sw-lan2(config)# interface vlan 1
  • sw-lan2(config-if)# ip address  192.168.11.2  255.255.255.0
  • sw-lan2(config-if)# no shutdown
  • sw-lan2(config-if)# exit
  • sw-lan2(config)# default-gateway 192.168.11.1
  • sw-lan2(config)# end
  • sw-lan2#
  • R1 interface s0/0/0 konfiguration
  • R1(config)#interface serial 0/0/0
  • R1(config-if)#description Link to R2
  • R1(config-if)#ip address  209.165.200.225  255.255.255.252
  • R1(config-if)#clock rate 128000
  • R1(config-if)#no shutdown
  • R1(config-if)#exit
  • R2 grundkonfiguration
  • Router> enable
  • Router# configure terminal
  • Router(config)# hostname R2
  • R2(config)#
  • R2 interface s0/0/0 konfiguration
  • R2(config)#interface serial 0/0/0
  • R2(config-if)#description Link to R1
  • R2(config-if)#ip address  209.165.200.226  255.255.255.252
  • R2(config-if)#no shutdown
  • R2(config-if)#exit
  • R2 interface g0/0 konfiguration
  • R2(config)# interface gigabitEthernet 0/0
  • R2(config-if)# description Link to LAN 3
  • R2(config-if)# ip address 10.1.1.1  255.255.255.0
  • R2(config-if)# no shutdown
  • R2(config-if)#exit
  • Switch sw-lan3 grundkonfiguration
  • Switch> enable
  • Switch# configure terminal
  • Switch(config)# hostname sw-lan3
  • sw-lan3(config)# end
  • sw-lan3#
  • R2 interface g0/1 konfigurationer
  • R2(config)# interface gigabitEthernet 0/1
  • R2(config-if)# description Link to LAN 4
  • R2(config-if)# ip address 10.1.2.1  255.255.255.0
  • R2(config-if)# no shutdown
  • R2(config-if)#exit
  • Switch sw-lan4 grundkonfiguration
  • Switch> enable
  • Switch# configure terminal
  • Switch(config)# hostname sw-lan4
  • sw-lan4(config)# end
  • sw-lan4#

Konfigurera an IPv4 Loopback interface

En annan vanlig konfiguration av Cisco routrar är loopback-interface. Det är ett logiskt interface och inte ett fysiskt interface och därför kan inte anslutas fysiskt med en annan nätverksenhet. Det används av routern själv och är alltid igång så länge som routern fungerar. Loopback-interfacet är användbart vid testning av konfigurationer eftersom det säkerställer att minst ett interface alltid kommer att vara tillgängligt. Det kan till exempel användas för teständamål där interfacet emulerar ett nätverk ansluten till routern. Dessutom kan IPv4-adressen tilldelad till loopback-interfacet vara signifikant för processer där routern behöver identifieras av ett alltid fungerande interface.

Att aktivera och tilldela en loopback-adress är enkel:

Bild 4: Loopback-interface
  • R1>enable
  • R1#configure terminal
  • R1(config)#interface loopback 0
  • R1(config-if)#ip address 10.0.0.1 255.255.255.0
  • R1(config-if)#exit

Flera loopback-interface kan aktiveras på en och samma router. IPv4-adressen för varje loopback-interface måste vara unik.

Kommandot no shutdown

När kommandot no shutdown exekveras visas meddelande liknande nedan:

*Mar 1 01:16:08.212: %Link-3-UPDOWN: interface FastEthernet0/0, changed state to up

*Mar 1 01:16:09.214: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Båda meddelande är viktiga.

  • Det första meddelandet anger att uppkopplingen är fysiskt fungerande.
  • Det andra meddelande anger att datalänk skiktet är i drift.

Obs: Även om kommandot no shutdown aktiverar ett interface, så blir det inte aktivt förrän interfacet börjar ta emot signaler.

Verifieringar

Det finns flera show-komando som kan användas för att verifiera konfigurationer. Poängen är det att ta fram information som visar konfigurationerna.

Följande tre kommando är mest användbara:

  • show ip interface brief – visar en sammanfattning av alla interface på en router, inklusive IP-adresser och status
  • show ip route – visar innehållet i routing-tabellen som finns i RAM-minnet. I Cisco IOS version 15 visas aktiva interface med två associerade rader markerade med bokstaven C (connected) eller L (local). I äldre IOS versioner visas aktiva interface markerade endast med bokstaven C.

    Bild 5: Show ip route
  • show running-config interface xx– visar alla kommando som har exekveras på interfacet.

När en routers interface status och protocol visar interfacet som “up” betyder att interfacet fungerar på det fysiska skiktet och på det datalänk skiktet. Annars är deras status “administratively down

Verifiering av IPv4 konfigurationer

Liknande IOS kommando plus nummer 6. Däremot utdatan visar intressanta detaljer

  • show ipv4 interface brief – visar minst två IPv6-adresser, den unicast globala och den link-local som börjar med FE80. En link-local adress skapas automatiskt när en IPv6 unicast global adress konfigureras.
  • show ipv4 interface gigabitethernet 0/0 – exempel som visar status på interfacet tillsammans med IPv6 adresser. Utdatan inkluderar IPv6 multicast adresser tilldelat till interfacet och som börjar med prefix FF02
  • show ipv4 route – visar endast IPv6-nätverk och inte IPv4. IPv6-nätverk markeras också med bokstäverna C och L. Det inkluderas också prefix och prefixlängden. Lokala route markeras med bokstaven L och prefixet /128. En sådan adress kan användas som destination i routing-processer.

Kommandot show

Vissa kommando kan generera flera sidor (samma storlek som skärmen). Varje sida pausas efter 24 rader då visas –More– -texten. Genom att trycka på Enter visas nästa rad och på mellanslagstangenten visas nästa sida med 24 rader till. Använd kommandot terminal length för att ange antalet rader som ska visas. Ett värde på 0 (noll) hindrar routern från att pausa mellan sidorna.

En annan mycket användbar funktion som förbättrar kommandoexekvering är filtreringen av show kommandot. För att aktivera filtreringskommandot, ange ett pipe (|) tecken efter show-kommandot och ange sedan en filtreringsparameter och ett filtreringsuttryck.

Filtreringsparametrarna som kan konfigureras efter pipe inkluderar:

  • section – Visar hela sektionen som börjar med filtreringsuttrycket
  • include – Inkluderar alla rader som matchar filtreringsuttrycket
  • exclude – Utesluter alla rader som matchar filtreringsuttrycket
  • begin – Visar alla rader från en viss punkt, börjar med raden som matchar filtreringsuttrycket

Obs! Filtreringsparametrarna kan användas i kombination med alla show-kommandon. Tråkig nog inte alla kommando fungerar beroende på IOS versionen.

Exempel:

  • R1# show running-config | section line vty
  • R1# show ip interface brief | include up
  • R1# show ip interface brief | exclude unassigned
  • R1# show ip route | begin Gateway

Kommandohistorik

Alla använda kommando lagras så att de kan återanvändas genom att trycka på piltangenterna upp och ned. För att se vilka kommando finns i historik-minnet tryck på Ctrl+N. Som default lagras 10 kommando eller rader i exekveringar. Kommandot show history visar lagrade innehåll i historik-minnet. Använd, i privilegierade exekveringsläget kommandot terminal history size för att ändra minnets storleken.