VLAN implementering

Varje VLAN anses vara ett separat logiskt nätverk adresserade med specifika nätverksadresser. Bilden nedan illustrerar ett fysiskt nätverk med fyra switchar placerade i olika våningar i en byggnad. På varje våning finns tre avdelningar med datorer ihopkopplade till samma switch. Datorerna tillhör till tre olika logiska nätverk: IT, HR och Sales. Var och en av dessa tre logiska nätverk adresseras med egna nätverksadresser.

Bild 1: Virtuella LAN – VLAN

VLAN konfiguration

På varje switch behöver skapas och konfigureras VLAN 2, VLAN 3, och VLAN 4. VLAN 1 finns redan som default och det är ett VLAN som inte går att ta bort eller ändra dess namn. Switcharna konfigureras med namn som S0 (bottenvåning), S1 (först våning), S2 (andra våning), och S3 (tredje våning). Av praktiska skäl anges här endast switch S1 konfigurationer

  • S1(config)#vlan 10
  • S1(config-vlan)#name Engineers
  • S1(config-vlan)#exit
  • S1(config)#vlan 20
  • S1(config-vlan)#name Designers
  • S1(config-vlan)#exit
  • S1(config)#vlan 30
  • S1(config-vlan)#name IT
  • S1(config-vlan)#exit
  • S1(config)#
  • S1(config)#interface range fa0/1-5
  • S1(config-if-range)#switchport access mode
  • S1(config-if-range)#switchport access vlan 10
  • S1(config-if-range)#exit
  • S1(config)#interface range fa0/6-10
  • S1(config-if-range)#switchport access mode
  • S1(config-if-range)#switchport access vlan 20
  • S1(config-if-range)#exit
  • S1(config)#interface range fa0/11-15
  • S1(config-if-range)#switchport access mode
  • S1(config-if-range)#switchport access vlan 30
  • S1(config-if-range)#end
  • S1#show vlan brief

Samma konfigurationer görs på switcharna S2 och S3. Switchen i bottenvåningen, S0, har nästan samma konfiguration förutom att den switchen behöver inte port tilldelas.

Trunk port

Nu har alla tre switchar konfigurerats. Nästa steg är att konfigurera trunk-portarna som ansluter samman switcharna. Först den teoretiska grunden som förklarar hur switchar sorterar och ansluter nätverksenheter till samma VLAN. Det en switch inte kan göra är att koppla ihop olika VLAN, detta görs av en router.

Så switchar behöver läsa av styrinformation i ramarna eftersom där finns etikett som identifierar enskilda VLAN.

Switchar som stödjer VLAN-teknik markerar ramar (frames) med en etikett. Denna etikett kallas på engelska TAG och markerade ramar kallas på engelska “tagged trafik“. Allt annat datatrafik kallas “untagged trafik“.

Det innebär att nätverkstrafik från VLAN 2 markeras med ett etikett som associerar just med det virtuella LAN 2. Det samma gäller för VLAN 3 och 4.

Bild 4: Ethernet ram (frame) för VLAN

Anta att switchar ansluts enligt bilden nedan där switch S1 ansluts från port Fa 0/21 till switch S0 på port Fa 0/21. Det samma för S2 och S3:

  • S1(config)#interface fa0/21
  • S1(config-if-range)#switchport mode trunk
  • S1(config-if-range)#end

På liknande sätt konfigureras switcharna S2 och S3, men S0 kräver annorlunda konfigurationer:

  • S1(config)#interface range fa0/21 – 23
  • S1(config-if-range)#switchport mode trunk
  • S1(config-if-range)#exit
  • S1(config)#interface G0/1
  • S1(config-if-range)#switchport mode trunk
  • S1(config-if-range)#exit