Inter-VLAN routing

VLANs används för att segmentera ett switch-baserat nätverk. L2-switch, som Catalyst 2960-serien, kan konfigureras med över 4000 VLAN. En VLAN är en broadcast-domän, så datorer på separata VLAN kan inte kommunicera utan en router som kan dirigera nätverkstrafiken. Alternativt kan L3-switchar användas för att segmentera ett nätverk och dirigera nätverkstrafiken mellan segmenterade nätverk. Att dirigera nätverkstrafik mellan VLAN kallas Inter-VLAN routing.

Det finns tre alternativ för VLAN-routing:

  • Legacy inter-VLAN routing
  • Router-on-a-stick
  • L3 switching using SVIs

Legacy inter-VLAN routing

Till en början användes en router med flera interface anslutna till olika VLAN så att datatrafik kunde dirigeras. Ett sådan gammal arbetssätt kräver anslutning till portar som är tillhörande till någon VLAN.

Bild 1: Trunk funktion

Portar i switchen som är anslutna till router konfigureras i access arbetsläge (mode). Varje interface konfigureras för att hantera datatrafik från specifika VLAN. Till exempel switchens port F0/1 är ansluten till routers port G0/0 och genom den anslutning cirkulerar VLAN 10 nätverkstrafik.

Konfigurationer

  • S2# conf t
  • S2(config)# vlan 10
  • S2(confi-vlan)# vlan 30
  • S2(confi-vlan)# interface fa0/11
  • S2(confi-if)# switchport access vlan 10
  • S2(confi-if)# interface fa0/1
  • S2(confi-if)# switchport access vlan 10
  • S2(confi-vlan)# interface fa0/6
  • S2(confi-if)# switchport access vlan 30
  • S2(confi-if)# interface fa0/2
  • S2(confi-if)# switchport access vlan 30
  • S2(confi-vlan)# end
  • S2#
  • R1# conf t
  • R1(config)# interface g0/0
  • R1(config-if)# ip address 172.17.10.1 255.255.255.0
  • R1(config-if)# no shut
  • R1(config-if)# interface g0/1
  • R1(config-if)# ip address 172.17.30.1 255.255.255.0
  • R1(config-if)# no shut
  • R1(config-if)# end
  • R1# show ip route
  • PC1 IP 172.17.10.21, 255.255.255.0, 172.17.10.1
  • PC3 IP 172.17.30.23 255.255.255.0, 172.17.30.1
  • ping på varandra.

Router-on-a-stick inter-VLAN routing

I dagens nätverk räcker att ett interface konfigureras för inter-VLAN routing. “Router-on-a-stick” är en typ av routerkonfiguration där ett enda fysiskt interface leder trafik mellan flera VLAN. Såsom ses i figuren är routern ansluten till switchen S1 med en enda fysisk nätverksanslutning (en trunk).

Routerns interface är konfigurerat som trunk och är anslutet till en trunk-port på en switch. Men interface är indelat i flera under-interface, ett till varje VLAN. Från switchens trunk-port skickas markerade data-frame till routers trunk-interface som tar emot och intern switchar till rätt under-interface som leder till rätt VLAN.

Bild 2: Subinterfaces

Sub-interface är mjukvarubaserat virtuella interface som hör samman med ett enda fysiskt interface. Varje sub-interface konfigureras med specifika IP-adresser tillhörande till en viss nätverksadress. När routern har hittat bästa vägen till rätt VLAN kapslar om frame  och markerar med destinations VLAN ID.

Konfigurationer

På nätverkstopologin illustrerad med bild 1 tar vi bort konfigurationer på länken F0/2 – G0/1. Först konfigurationer och därefter radera vi kabeln.

  • S2# configure terminal
  • S2(config)# int fa0/2
  • S2(config-if)# no switchport access vlan 30
  • S2(config-if)# int fa0/1
  • S2(config-if)# no switchport access vlan 10
  • S2(config-if)# switchport mode trunk
  • S2(config-if)# end
  • S2#
  • R1# config t
  • R1(config)# int g0/0
  • R1(config-if)# no ip address
  • R1(config-if)# shut
  • R1(config-if)# int g0/1
  • R1(config-if)# no ip address
  • R1(config-if)# exit
  • R1(config)# int g0/0.10
  • R1(config-subif)# encapsulation dot1q 10
  • R1(config-subif)# ip address 172.17.10.1 255.255.255.0
  • R1(config)# int g0/0.30
  • R1(config-subif)# encapsulation dot1q 30
  • R1(config-subif)# ip address 172.17.30.1 255.255.255.0
  • R1(config-subif)#interface g0/0
  • R1(config-if)# no shutdown
  • R1(config-if)# end
  • R1#