RIPv1 vs RIPv2

RIP Version 2 (RIPv2) definieras i RFC 1723. Även om RIPv2 har förbättrat sina routing-funktioner för vissa nätverksmiljöer har RIPv2 förlorat popularitet jämfört med andra routing-protokoll som EIGRP, OSPF och IS-IS. Routingprotokoll som EIGRP och OSPF erbjuder fler routing-funktioner för stora nätverk. Tros detta är RIPv2 fortfarande lämpligt för mindre homogena nätverk.

RIPv2 är faktiskt en vidareutveckling av RIPv1 som lyckades förbättra flera funktioner exempelvis:

  • Nästa hop-adresser som ingår i routing-uppdateringarna
  • Användning av multicast-adresser i uppdateringar
  • Autentiseringsalternativ

Liksom RIPv1 är RIPv2 ett distansvektor routingprotokoll därmed delar båda versioner funktioner och begränsningar. Här nedan anges de som är väsentliga:

  • Användning av holddown och andra timers för att förhindra routing-loopar.
  • Användning av split horisont eller split horisont med poison reverse för att förhindra routing-loopar.
  • Användning av trimmade (triggered) uppdateringar när det finns en förändring i topologin för snabbare konvergens.
  • Maximal hopp på 15 hopp, med hopp-räkningen 16 som oåtkomligt nätverk.

Skillnader mellan RIPv1 och RIPv2

Med hjälp av en nätverkstopologi tas upp detaljer i skillnader mellan RIPv1 och RIPv2. I topologin inkluderas nätverk med olika nätmask just för att se hur ett classful nätverk fungerar med RIPv1. Hittills har vi laborerat med nätverk och dess delnät med en och samma nätmask, men även om delnäten har nu olika nätmask fortfarande fungerar de som ett classful nätverk.

Bild 1: RIPv1 vs RIPv2 topologi

Observera följande i topologin:

  • att både R1 och R3-routrarna har delnät som ingår i 172.30.0.0/16 stora classful nätverket (klass B).
  • att R1 och R3 är anslutna till R2 med hjälp av delnätet i 209.165.200.0/24 classful nätverket (klass C).
  • Denna topologi är diskontinuerlig och kommer inte att konvergera i RIPv1 eftersom 172.30.0.0/16 nätverk splittras med 209.165.200.0/24.
  • Den publika adressen 209.165.200.224/27 har uppdelats i /30 delnät d.v.s 3 hostbitar till med vilka kan genereras 8 nätadresser till:
    • 209.165.200.224/30
    • 209.165.200.228/30 WAN-länk mellan R1 och R2
    • 209.165.200.232/30 WAN-länk mellan R2 och R3
    • 209.165.200.236/30
    • 209.165.200.240/30
    • 209.165.200.244/30
    • 209.165.200.248/30
    • 209.165.200.252/30.

Konfigurationer

  • R1# configure terminal
  • R1(config)# interface fa0/0
  • R1(config-if)# ip address 172.30.1.1 255.255.255.0
  • R1(config-if)# no shutdown
  • R1(config-if)#interface fa0/1
  • R1(config-if)# ip address 172.30.2.1 255.255.255.0
  • R1(config-if)# no shutdown
  • R1(config-if)# interface s0/0/0
  • R1(config-if)# Description Mot R2
  • R1(config-if)# ip address 209.165.200.230 255.255.255.252
  • R1(config-if)# clock rate 64000
  • R1(config-if)# end
  • R1#
  • R2# configure terminal
  • R2(config)# int fa0/0
  • R2(config-if)# ip address 10.1.0.1 255.255.0.0
  • R2(config-if)# no shutdown
  • R2(config-if)# interface s0/0/0
  • R2(config-if)# description Mot R1
  • R2(config-if)# ip address 209.165.200.229 255.255.255.252
  • R2(config-if)# no shutdown
  • R2(config-if)# interfacce s0/0/1
  • R2(config-if)# description Mot R3
  • R2(config-if)# ip address 209.165.200.233 255.255.255.252
  • R2(config-if)# clock rate 64000
  • R2(config-if)# no shutdown
  • R2(config-if)# exit
  • R2(config)# ip route 192.168.0.0 255.255.0.0 Null0
  • R2(config)# end
  • R2#
  • R2# show ip int br
  • R3# configure terminal
  • R3(config)# interface fa0/0
  • R3(config-if)# ip address 172.30.100.1 255.255.255.0
  • R3(config-if)# no shutdown
  • R3(config-if)# interface s0/0/1
  • R3(config-if)# description Mot R2
  • R3(config-if)# ip address 209.165.200.234 255.255.255.252
  • R3(config-if)# no shutdown
  • R3(config-if)# interface lo0
  • R3(config-if)# ip address 172.30.110.1 255.255.255.0
  • R3(config-if)# no shutdown
  • R3(config-if)# interface lo1
  • R3(config-if)# ip address 172.30.200.17 255.255.255.240
  • R3(config-if)# no shutdown
  • R3(config-if)# interface lo2
  • R3(config-if)# ip address 172.30.200.33 255.255.255.240
  • R3(config-if)# no shutdown
  • R1# configure terminal
  • R1(config)# router rip
  • R1(config-router)# network 172.30.1.0
  • R1(config-router)# network 172.30.2.0
  • R1(config-router)# network 209.165.200.228
  • R1(config-router)# end
  • R1#
  • R2# configure terminal
  • R2(config)# router rip
  • R2(config-router)# network 10.1.0.0
  • R2(config-router)# network 209.165.200.228
  • R2(config-router)# network 209.165.200.232
  • R2(config-router)# end
  • R2#
  • R3# configure terminal
  • R3(config)# router rip
  • R3(config-router)# network 172.30.100.0
  • R3(config-router)# network 209.165.200.232
  • R3(config-router)# network 172.30.110.0
  • R3(config-router)# network 172.30.200.16
  • R3(config-router)# network 172.30.200.32
  • R3(config-router)# end
  • R3#

Summary route

  192 168                 00000000
192.168.0.0 11000000 10101000 0 0 0 0 0 0 0 0  
192.168.1.0 11000000 10101000 0 0 0 0 0 0 0 1  
192.168.2.0 11000000 10101000 0 0 0 0 0 0 1 0  
192.168.3.0 11000000 10101000 0 0 0 0 0 0 1 1  
. . . . .                      
192.168.253.0 11000000 10101000 1 1 1 1 1 1 0 0  
192.168.254.0 11000000 10101000 1 1 1 1 1 1 1 0  
192.168.255.0 11000000 10101000 1 1 1 1 1 1 1 1  
192.168.0.0 11000000 10101000 0
0 0 0 0 0 0 0 00000000
  • R2# configure terminal
  • R2(config)# ip route 192.168.0.0 255.255.0.0 192.168.254.254
  • R2(config)# end
  • R2# show ip route

Router R1 routing-tabellens post:

  • R 10.0.0.0/8 [120/1] via 209.165.200.229 Serial0/0/0
  • R 209.165.200.32 [120/1] via 209.165.200.229 Serial0/0/0

Router R2 routing-tabellens post:

  • R 172.30.0.0/16 [120/1] via 209.165.200.230 Serial0/0/0
  •                               [120/1] via 209.165.200.234 Serial0/0/1

Router R3 routing-tabellens post:

  • R 10.0.0.0/8 [120/1] via 209.165.200.233 Serial0/0/1
  • R 209.165.200.228 [120/1] via 209.165.200.233 Serial0/0/1

Route aggregering

Topologin visar att R2 har en statisk aggregerad route till 192.168.0.0/16-nätverket. Statiska aggregerade route kan inkluderas i routing-uppdateringar så att informationen kan spridas ut i nätverket. Detta kallas route-omfördelning eller på engelska route redistribution. En sådan funktion komplicerar routing i RIPv1 protokollet på grund av att det är en classful routing-protokoll och som sådant inkluderar inte statiska route i uppdateringar. Slutligen visar topologin att R1 och R3 routrarna innehåller VLSM-nätverk och delar adressutrymme från det 172.30.0.0/16 stora classful nätverket.

RFC 1918 Privata Adresser

Bild 2: Privata IP adresser

Privata IP adresser specificeras i dokumentet RFC 1918. Privata IP adresser får användas fritt i lokala nätverk som är just privata, vilket innebär att privata IP adresser får inte användas i allmänna eller publika nätverk såsom Internet. När privata IP adresser används i ett lokalt nätverk, tillsammans med en NAT server, är möjligt att dirigera den lokala datatrafiken till allmänna nätverk.

  • A – 10.0.0.0/8 ——— 10.0.0.0 till 10.255.255.255
  • B – 172.16.0.0/12 —— 172.16.0.0 till 172.31.255.255
  • C – 192.168.0.0/16 —- 192.168.0.0 till 192.168.255.255

Förutom privata IP adresser är flera andra IP adresser reserverade till olika ändamål, exempelvis när de används i olika böcker. Cisco använder i sina exempel flera olika reserverade IP adresser exempelvis 209.165.200.0/27. En sådan block av IP adresser är egentligen en publik adress, men den används endast i Ciscos laborationsmiljö. Men när IP-trafik dirigeras över WAN-länkar via en Internetleverantör, eller när användarna behöver komma åt externa webbplatser måste publika IP-adresser användas.

Loopback interface – Lo

Ett loopback-interface är programbaserat interface som används för att emulera ett fysiskt interface. Liksom andra interface kan loopback interface tilldelas en IP-adress. Ett loopback-interface kan pingas och delnätet kan inkluderas i routing-uppdateringar. I en laborationsmiljö är loopback-interface användbara för att skapa ytterligare nätverk utan att behöva lägga till fler fysiska interface på routern. Loopback interface är idealiska för att simulera flera nätverk kopplade till samma router. I vårt exempel behöver R3 inte 4 fysiska LAN-interface för att visa flera VLSM delnät. Istället använder router R3 loopback-interface.

  • Adressen 172.30.0.0/16 delas upp till /24 delnät och resulterar: 172.30.0.0/24, 172.30.1.0/24, 172.30.2.0/24, 172.30.3.0/24 och så vidare fram till 172.30.255.0. Därav tilldelas adresserna:
    • R1: Fa0/0 172.30.1.1 och Fa0/1  172.30.2.1
    • R2 Fa0/0 172.30.100.1, Lo0 172.30.110.1; Lo1 172.30.200.17; Lo2 172.30.200.33
  • Adressen 172.30.200.0/24 delas upp ytterligare till /28 delnät (255.255.255.240) och resulterar i 172.30.200.0/28, 172.30.200.16/28, 172.30.200.32/28 och så vidare. Från dessa adresser tilldelas några till R3 interface Lo1 och Lo2.

Statiska route och Null-interface

Bild 3: Statisk supernät route

För att konfigurera den aggregerade vägen 192.168.0.0/16 (route) på R2 används följande kommando:

R2 (config) #ip-route 192.168.0.0 255.255.0.0 Null0

Kom ihåg att route aggregering tillåter att en enda övergripande route representera många andra route. Detta reducerar storleken på routing-tabellerna. Den statiska route på R2 använder en /16 nätmask för att aggregera alla 256 nätverk som sträcker sig från 192.168.0.0/24 till 192.168.255.0/24.

Adressutrymmet som representeras med den statisk aggregerade vägen 192.168.0.0/16 existerar faktiskt inte. För att simulera den här statiska vägen använder vi ett null-interface som utgångsinterfacet. Du behöver inte ange några kommandon för att skapa eller konfigurera null-interfacet. Det är alltid upp men skickar inte eller tar emot trafik. Trafiken som skickas till null-interfacet kasseras, interfacet fungerar som en virtuell utgång. Genom att använda null-interfacet kan routing information i router R2 inkludera den statiska vägen, även om den aggregerade route 192.168.0.0/16 inte existerar.

Route-omfördelning eller på engelska Route Redistribution

Det andra kommandot som måste anges är redistribute static kommando:

  • R2 (config-router) #redistribute static

RIP inkluderar inte statiska route i uppdateringar som skickas ut till andra routrar. Det kan ändras med kommandot redistribute static. I vår exempeltopologi vill vi att RIP-processen på R2 ska inkludera den statiska och aggregerade vägen (192.168.0.0/16) i RIP processen genom att importera routen i processen och därefter skicka den till R1 och R3.

Diskontinuerliga nätverk

Bild 4: RIPv1 meddelande format

Om du tänker exempelvis på alfabetet som börjar på a, b, c, d och så vidare kan man väl säga att varje bokstav har en vis position, eller att bokstäverna är kontinuerliga. Men när man ändrar ordningen är det istället diskontinuerliga, även om fortfarande är de i alfabetet. Det samma händer med IP adresser där nätmasken definierar om adresserna som kontinuerliga eller diskontinuerliga.

Du vet redan att RIPv1 är ett classful routingprotokoll som inte inkluderar nätmasken i routing-informationen, därmed nätmasken inte finns i routing-uppdateringar. Detta kan bekräftas genom att kontrollera RIPv1 meddelandets format.

I meddelandes formatet för RIPv1 finns inte utrymme för nätmaskerna därmed kan RIPv1 inte särskilja ordningen på delnäten och deras classful IP nätverksadresser. RIPv1 stödjer inte diskontinuerliga nätverk, VLSM eller Classless Inter-Domain Routing (CIDR) nätverk.

Bild 5: RIP uppdateringar från R1 och R3

Observera att R2 har två lika kostnadsledningar till 172.30.0.0/16-nätverket. Detta beror på att både R1 och R3 sänder till router R2 en RIPv1-uppdatering för det 172.30.0.0/16 classful nätverket med ett avstånd 1 hopp.

Eftersom R1 och R3 aggregerade de enskilda delnät automatiskt innehåller R2: s routing-tabell bara den stora classful nätverksadressen till 172.30.0.0/16. Det resulterar att R2 känner bara om det 172.30.0.0/16 classful nätverket och den är inte medvetet om några 172.30.0.0-delnät.

Kommandot debug ip rip

Även om router R2 tar emot uppdateringar i vilka inkluderas den aggregerade route 172.30.0.0/16 skickar inte router R2 denna route tillbaka till R1 och R3. Det här kan bekräftas med kommandot debug ip rip på router R2. Nu är det frågan varför inte skickas tillbaka samma route till routrarna R1 och R3?

Svaret är att regeln Split Horisont är i kraft och den tillåter inte att skicka tillbaka en route som ursprungligen har tagits emot från samma interface.

RIPv1 stödjer inte VLSM

Eftersom RIPv1 inte skickar nätmasken i routing-uppdateringar kan det inte stödja VLSM. Router R3 är konfigurerad med VLSM-delnät som alla är medlemmar i klass B-nätverket 172.30.0.0/16:

  • 172.30.100.0/24 (FastEthernet 0/0)
  • 172.30.110.0/24 (Loopback 0)
  • 172.30.200.16/28 (Loopback 1)
  • 172.30.200.32/28 (Loopback 2)

Alla dessa delnät IP adresser representeras med den aggregerade route 172.30.0.0/16. RIP bestämmer vilka delnät som ska inkluderas i routing-uppdateringar genom att välja den classful aggregerade nätmasken eller den nätmasken som det utgående interfacet använder.

Bild 6: Hur definieras nätmask i RIPv1

För att visa hur RIPv1 använder nätmasken för det utgående interfacet läggs R4 till topologin. Router R4 är ansluten till R3 via FastEthernet 0/0 interface på 172.30.100.0/24-nätverket. Figuren visar att router R3 väljer nätmasken /24 och routern skickar till R4 route adresserad som 172.30.110.0/24. Däremot inkluderas inte /28 delnäten.

Routern R3 behöver bestämma vilka 172.30.0.0-delnät som ska inkluderas i routing-uppdateringarna. I enlighet med hur ett classful routing fungerar R3 väljer att använda som nätmask det utgående interfacets nätmask.

RIPv1 stödjer inte CIDR

Hittills har vi konfigurerat en statisk route till 192.168.0.0/16 på router R2 och vi har konfigurerat RIP så att denna route inkluderas i uppdateringar genom att exekvera kommandot redistribute static. Konfigurationer har utförts så här:

Bild 7: Kommando redistribute static
  • R2(config)#router rip
  • R2(config-router)#redistribute static
  • R2(config-router)#network 10.0.0.0
  • R2(config-router)#network 209.165.200.0
  • R2(config-router)#exit
  • R2(config)#ip route 192.168.0.0 255.255.0.0 null0

Med kommando show ip route kan vi bekräfta att den aggregerade route 192.168.0.0/16 finns i router R2 routing-tabell. Men när vi kör samma kommando på router R1 kommer vi att bekräfta att samma route inte finns i routers R1 routing-tabell.

Med hjälp av kommandot debug ip rip på router R2 märker vi att RIPv1 inte inkluderar 192.168.0.0/16 route i sina RIP-uppdateringar till R1 och R3. Som förklaring till detta hänvisade vi till regeln Split Horisont, men det finns fler förklaringar. Titta på den aggregerade route 192.168.0.0/16. Till vilken klass tillhör denna adress? Klass A, B eller C? Vad för nätmask använder dessa klasser?

Vi konfigurerade den statiska vägen 192.168.0.0 med en /16 nätmask. Detta består av färre bitar än den classful klass C nätmasken på /24. Eftersom nätmasken inte överensstämmer med klassen kommer RIPv1 inte att inkludera denna route i dess uppdateringar till andra routrar. RIPv1 och andra classful routing-protokoll kan inte stödja CIDR route som är aggregerade till en mindre nätmask än den korrekta nätmasken.

Obs! Om den statiska vägen för 192.168.0.0 konfigurerades med en /24 mask eller högre, skulle denna route inkluderas i RIP-uppdateringarna. Mottagande routrar skulle tillämpa den classful /24 nätmasken till den här uppdateringen.

Jämförelse av RIPv1 och RIPv2 meddelandeformat

Bild 8: RIPv1 och RIPv2 meddelande format

RIPv2 är definierad i RFC 1723. Liksom version 1 inkapslas RIPv2 i ett UDP-segment med port 520 och kan bära upp till 25 route. Även om RIPv2 har samma grundläggande meddelandeformat som RIPv1, läggs två signifikanta tillägg.

  • Den första förlängningen i RIPv2-meddelandet är fältet Subnet Mask som gör det möjligt att inkludera en 32-bitars mask i en RIP route.
  • Den andra signifikanta utvidgningen till formatet RIPv2 är tillägget av Next Hop adressen. Denna adressen används för att vidarebefordra meddelande som skickas till en viss destination. Om fältet är inställt på alla nollor (0.0.0.0) är den default adress som skickar router alla meddelande.

Som standard körs på en Cisco router RIPv1 när en RIP-process konfigureras. Men trots att routern bara skickar RIPv1-meddelanden kan den tolka både RIPv1 och RIPv2-meddelanden. En RIPv1-router ignorerar fältet Router Tag.

Kommandot show ip protocol verifierar att R2 är konfigurerat för RIPv1 men mottar RIP-meddelanden för båda versionerna.

Aktivering av RIPv2

Med kommandot version 2 modifieras RIP versionen och aktiveras version 2. Det här kommandot ska konfigureras på alla routrar i routing-domänen:

  • R1(config)#router rip
  • R1(config-router)#version 2
  • R2(config)#router rip
  • R2(config-router)#version 2
  • R3(config)#router rip
  • R3(config-router)#version 2

RIP-processen kommer nu att inkludera nätmasken i alla uppdateringar vilket gör RIPv2 till ett classless routing-protokoll. Men RIPv2-routrar skickar och mottar endast RIPv2-meddelanden. Det kan hända ibland att man vill återställa routrarna till RIPv1 och då exekveras följande kommando:

  • Router(config)#router rip
  • Router(config-router)version 1

Automatisk IP adress aggregering och RIPv2

Bild 9: R2 show ip route

Eftersom RIPv2 är ett classless routing-protokoll bör man se nu de individuella 172.30.0.0 delnät i routrarnas routing-tabell. Men när man granskar routing-tabellen för R2 kan man konstatera att fortfarande den sammanfattade 172.30.0.0/16 route med samma två lika kostnad finns med i routing-tabellen och inte de individuella delnäten från routrar R1 och R3. Det innebär att routrarna R1 och R3 inkluderar fortfarande inte de olika 172.30.0.0 delnät i sina RIP-uppdateringar. Så vad händer?

När kommandot show ip route körs på router R1 kan konstateras att den aggregerade route 192.168.0.0/16 är med i routing-tabellen och inte de individuella delnäten från router R2, trots att RIPv2 är det aktiva routing-protokollet. För att få mer information kan exekveras kommandot show ip protocols.

  • R1#show ip protocols
Bild 10: R1 show ip route

Resultatet visar “Automatic network summarization is in effect” eller att adress aggregering gäller.

Som standard aggregerar RIPv2 automatiskt nätverksadresser med övergripande nätmask, precis som RIPv1. Både R1 och R3-routrar fortfarande aggregerar delnäten adresser till klass B-adressen 172.30.0.0 delnät.  Rörande den andra aggregerade statisk route 192.168.0.0 /16 (istället /24) kan bekräftas att den är med på router R1. Det innebar att router R2 fortsätter att inkludera adressen i sina RIP-uppdateringar. Det är ett fel som genererades när till en början konfigurerades RIPv1 och att den aggregerade route skulle inkluderas/redistribueras i alla RIP-uppdateringar.

Felsökning

För att undersöka vilka RIPv2-route som skickas och mottas använder vi kommandot debug ip rip.

Bild 11: R1 debug ip rip
  • R1#debug ip rip
    • RIP: sending v2 update to 224.0.0.9 via Serial0/0/0 (209.165.200.230)
    • RIP: build update entries
      • 172.30.0.0/16 via 0.0.0.0, metric 1, tag 0
    • Observera att R1 fortfarande skickar ut den aggregerade route 172.30.0.0 men nu med nätmasken /16, dock inte delnäten.
    • RIP: received v2 update from 209.165.200.229 on Serial0/0/0
      • 10.0.0.0/8 via 0.0.0.0 in 1 hops
      • 192.168.0.0/16 via 0.0.0.0 in 1 hops
      • 209.165.200.232/30 via 0.0.0.0 in 1 hops
    • Observera att den aggregerade route 192.168.0.0/16 tas emot

Inaktiverar automatisk IP adress aggregering i RIPv2

För att ändra den standard RIPv2 beteendet för automatisk IP adress aggregering använd kommandot no auto-summary i routerns konfigurationsläge.

  • R1(config)#router rip
  • R1(config-router)#no auto-summary
  • R1(config-router)#end
  • R1#show ip protocols
Bild 12: Kommando no auto-summary

Kommandot no auto-summary är inte giltigt i RIPv1. Även om till synes Cisco IOS accepterar kommandoexekveringen men utan något effekt. Det innebar att automatisk IP adress aggregering aktiveras av endast i RIPv2. När den automatiska aggregering har inaktiverats kommer RIPv2 inte längre att aggregera delnätens IP adresser till sin classful adress. RIPv2 kommer nu att inkludera alla delnät och deras respektive nätmasker i routing uppdateringar. Kommandot show ip protocols kan användas för att verifiera att “automatisk nätverkssammanfattning inte är i kraft.”

Nu när vi använder ett classless routing-protokoll, RIPv2, och när vi också har aktiverat av automatisk aggregering vad ska vi förvänta oss att se i routrarnas routing-tabeller?

Bild 13: R1 show ip route

Bild 12: R2 show ip route

Bild 14: R3 show ip route

I figurerna ovan visas att nu innehåller routing-tabellerna de enskilda delnäten med respektive nätverksadresser och nätmask. Observera att det inte längre finns den aggregerade route som omfattar flera 172.30.0.0 /16 delnät och inte längre några route med lika stora kostnadsvägar.

Bild 15: RIPv2 uppdateringar
  • Router R1
    • R 172.30.200.32/28 [120/2] via 209.165.200.229, Serial0/0/0
    • R 172.30.200.16/28 [120/2] via 209.165.200.229, Serial0/0/0
    • R 172.30.100.32/24 [120/2] via 209.165.200.229, Serial0/0/0
    • R 172.30.110.32/24 [120/2] via 209.165.200.229, Serial0/0/0
    • Observera att det finns också följande adresser:
      • R 10.1.0.0  [120/1] via 209.165.200.229, Serial0/0/0
      • R 192.168.0.0/16 [120/1] via 209.165.200.229, Serial0/0/0
  • Router R2
    • R 172.30.200.32/28 [120/1] via 209.165.200.234, Serial0/0/1
    • R 172.30.200.16/28 [120/1] via 209.165.200.234, Serial0/0/1
    • R 172.30.2.0/24 [120/1] via 209.165.200.230, Serial0/0/0
    • R 172.30.1.0/24 [120/1] via 209.165.200.230, Serial0/0/0
    • R 172.30.100.0/24 [120/1] via 209.165.200.234, Serial0/0/1
    • R 172.30.110.0/24 [120/1] via 209.165.200.234, Serial0/0/1
    • Observera att det finns också den statisk aggregerade route
      • S  192.168.0.0/16 is directly connected, Null0
  • Router R3
    • R 172.30.2.0/24 [120/2] via 209.165.200.233, Serial0/0/0
    • R 172.30.1.0/24 [120/2] via 209.165.200.233, Serial0/0/0
    • Observera att det finns också följande adresser:
      • R 209.165.200.228 [120/1] via 209.165.200.233, Serial0/0/1
      • R 10.1.0.0 [120/1] via 209.165.200.233, Serial0/0/1
      • R 192.168.0.0/16 [120/1] via 209.165.200.233, Serial0/0/1

Observera också att uppdateringarna skickas med hjälp av multicast-adressen 224.0.0.9. RIPv1 skickar uppdateringar som en broadcast med adressen 255.255.255.255. Det finns flera fördelar med att använda en multicast-adress istället exempelvis mindre bandbredd i nätverket. Dessutom kräver multicasting uppdateringar mindre behandling av routrar som inte är RIP-aktiverade.

RIPv2 och VLSM

Eftersom klasslösa routing-protokoll som RIPv2 kan bära både nätverksadressen och nätmasken behöver de inte sammanfatta dessa nätverk till sina classful adresser vid stora nätverksgränser. Därför stöder klasslösa routingprotokoll VLSM. Routrar som använder RIPv2 behöver inte längre använda inkommande gränssnittets mask för att bestämma nätmasken i ruttannonseringen. Nätverket och masken ingår uttryckligen i varje routing-uppdatering.

I nätverk som använder ett VLSM-adresseringsschema är ett klasslöst routing-protokoll viktigt för att sprida alla nätverk tillsammans med deras korrekta nätmasker. Om vi ​​tittar på utsignalen från debug ip rip för R3 i figuren kan vi se att RIPv2 inkluderar nätverket och deras nätmasker i sina routing-uppdateringar.

Observera också i figuren att vi än en gång har lagt till R4-routern i topologin. Kom ihåg att med RIPv1 skulle R3 bara skicka R4 172.30.0.0-rutorna som hade samma mask som FastEthernet 0/0-utgångsgränssnittet. Eftersom gränssnittet är 172.30.100.1 med en / 24-mask, inkluderade RIPv1 endast 172,30,0,0 delnät med a / 24 mask. Den enda vägen som uppfyllde detta villkor var 172.30.110.0.

Men med RIPv2 kan R3 nu inkludera alla 172.30.0.0-delnät i sina routing-uppdateringar till R4, som visas i felsökningseffekten i figuren. Detta beror på att RIPv2 kan innehålla rätt nätverksmask med nätverksadressen i uppdateringen.

RIPv2 och CIDR

Classless routing-protokoll såsom RIPv2 stödjer VLSM och CIDR. Ett av målen för Classless Interdomain Routing (CIDR), enligt RFC 1519, är att “tillhandahålla en mekanism för IP adress aggregering i routing-informations processen.” Detta mål inkluderar begreppet supernetting. Ett supernät är ett block av classful nätverk som adresseras med ett enda nätverk. På R2-routern konfigurerade vi ett supernät – en statisk rutt till ett enda nätverk som används för att representera flera nätverk eller delnät. Supernät har masker som är mindre än den classful masken exempelvis /16 istället /24. För att supernätet ska ingå i en routing-uppdatering måste routing-protokollet ha förmåga att acceptera en sådan nätmask, till exempel RIPv2.

Autentisering

De flesta routingprotokoll skickar sina routing-uppdateringar och annan routing-information med hjälp av IP (i IP-paket). IS-IS är det anmärkningsvärda undantaget och diskuteras i CCNP-kurser. Ett säkerhetsproblem för ett routingprotokoll är möjligheten att acceptera ogiltiga routing-uppdateringar. Källan till dessa ogiltiga routing-uppdateringar kan vara en angripare som försöker störa nätverket eller försöker fånga paket genom att lura routern till att skicka uppdateringar till fel destination. En annan källa till ogiltiga uppdateringar kan vara en felkonfigurerad router. Eller kanske en okänd host som är kopplad till nätverket.

Oavsett anledningen är det bra att autentisera routing-information som överförs mellan routrarna. RIPv2, EIGRP, OSPF, IS-IS och BGP kan konfigureras för att autentisera routing-information. Denna övning säkerställer att routrar endast accepterar routing-information från andra routrar som har konfigurerats med samma lösenord eller autentiseringsinformation.