RIP konfigurationer

Routrar som kör RIP hanterar en routing-databas som innehåller information om destinationsadresser. Varje destinationsadress associeras med nästa-hopp router eller med ett router-interface. En sådan association kallas route som leder till destinationsnätverket. Varje route i routing-databasen tilldelas ett mått (Metric) som anger avståndet till destinationen räknat i antal hopp eller routrar som paket passerar. Antal hopp är från 0 till 15.

När RIP aktiveras på en router skickar denna en begäran eller request om en uppdatering till närliggande routrar. När router får svar eller response i form av uppdatering uppdateras routing-databasen. RIP-uppdateringar görs varje trettionde sekund och därför kallas periodisk uppdateringar. Om en router tar inte emot RIP-uppdatering markeras den befintliga route som inaktiv under en viss tid. Om dessa markeringar inte uppdateras efter en uppsatt tid tas de bort från databasen därmed från routing-tabellen.

RIPv1 meddelande format

RIP använder UDP och därmed dess meddelande kallas för datagram även om det kallas endast paket. RIP-paket formateras med header och Route Entries.

Bild 1: RIPv1 format
  • Header
    • Command – indikerar om paketet är av typ 1 eller 2. 1 betyder request och 2 response
    • Version – indikerar RIP version. Version 1 identifieras med 0x01
    • Must be zero – indikerar reservationer till vidare utveckling eller att fälten används inte
  • Route entries
    • Address Family – identifierar protokollet:
      • 0 önskas hela routing-tabell i uppdateringar
      • 1 odefinierad
      • 2 identifiera protokollet IP
      • 3 – 65 534 odefinierade
      • 65 535 autentisering
    • IP address – identifierar destinationsnätverket
    • Metric – indikerar antal hopp

IANA definierar värdena ovan. Om du klickar på länken kommer du att se RIP parametrarna.

RIPv2 meddelande format

RIPv2 stödjer CIDR och VLSM och då har RIPv2-paket en annorlunda formatering eftersom i ett VLSM konfigurerat nätverk inkluderas nätmasken i alla RIP-uppdateringar.

Bild 2: RIPv2 format

Cisco-implementeringen av RIP Version 2 (RIPv2) stöder

  • textbaserat meddelande och MD5 autentiserings algoritm
  • route aggregering
  • CIDR
  • VLSM

Exempel 1

Här nedan anges alla nödvändiga kommando för att konfigurera routing i ett RIP-nätverk. Kommandot passive-interface som anges i routers konfigurationsläge stoppar onödiga RIP uppdateringar så att:

  1. Bandbredden används effektivare eftersom uppdateringsmängder minskar.
  2. Istället att ta emot och bearbeta uppdateringar ignorerar nätverksenheterna onödiga uppdateringar.
  3. Mindre uppdateringstrafik desto mindre säkerhetsrisker.
Bild 3: Laborations topologi – exempel 1

Konfigurationer

  • R1# configure terminal
  • R1(config)# interface fa0/0
  • R1(config-if)# ip address  172.30.1.1  255.255.255.0
  • R1(config-if)# no shutdown
  • R1(config-if)# exit
  • R1(config)# interface s0/0/0
  • R1(config-if)# ip address  172.30.2.1  255.255.255.0
  • R1(config-if)# clock rate 64000
  • R1(config-if)# no shutdown
  • R1(config-if)# exit
  • R1(config)# router rip
  • R1(config-router)# network 172.30.1.0
  • R1(config-router)# network 172.30.2.0
  • R1(config-router)# passive-interface FastEthernet 0/0
  • R1(config-router)# end
  • R1# show run
  • R1# show ip route
  • R2# configure terminal
  • R2(config)# interface s0/0/0
  • R2(config-if)# ip address 172.30.2.2  255.255.255.0
  • R2(config-if)# no shutdown
  • R2(config)# interface fa0/0
  • R2(config-if)# ip address 172.30.3.1  255.255.255.0
  • R2(config-if)# no shutdown
  • R2(config)# interface s0/0/1
  • R2(config-if)# ip address 192.168.4.9  255.255.255.252
  • R2(config-if)# clock rate 64000
  • R2(config-if)# no shutdown
  • R2(config-if)# exit
  • R2(config)# router rip
  • R2(config-router)# network 172.30.2.0
  • R2(config-router)# network 172.30.3.0
  • R2(config-router)# network 192.168.4.8
  • R2(config-router)# passive-interface FastEthernet 0/0
  • R2(config-router)# end
  • R2# show run
  • R2# show ip route
  • R3# configure terminal
  • R3(config)# interface fa0/0
  • R3(config-if)# ip address 192.168.5.1  255.255.255.0
  • R3(config-if)# no shutdown
  • R3(config-if)# exit
  • R3(config)# interface s0/0/1
  • R3(config-if)# ip address 192.168.4.10  255.255.255.252
  • R3(config-if)# no shutdown
  • R3(config-if)# exit
  • R3(config)# router rip
  • R3(config-router)# network 192.168.4.8
  • R3(config-router)# network 192.168.5.0
  • R3(config-router)# passive-interface FastEthernet 0/0
  • R3(config-router)#end
  • R3#show run
  • R3# show ip route

Vi studerar hur RIP hanterar VLSM IP adresser.

  • 172.30.0.0/24 har uppdelats i flera delnätadresser och de som används är kontinuerliga.
  • 192.168.4.8/30 har uppdelats i flera delnätadresser och de som används är inte kontinuerliga.
  • Observera att IP-adressen 192.168.4.8/30 representeras av en aggregerade IP-adress 192.168.4.0/24

Angränsade routrar och automatiskt route summering/aggregering

När man studerar denna nätverkstopologi märker vi att den består av två nätverk, det ena kontinuerligt och det andra icke kontinuerligt

  • 172.30.1.0, 172.30.2.0, 172.30.3.0 alla /24 som kan aggregeras till 172.30.0.0/16. Ett classful nätverk.
  • 192.168.4.8/30 och 192.168.5.0/24 som inte kan aggregeras eftersom de är inte kontinuerliga. Ett classless nätverk.
Bild 5: Boundary router

En router som är i mitten av ett classful nätverk och ett classless nätverk som använder diskontinuerliga IP adresser kallas angränsade eller “boundary router“. En sådan router kan också binda ihop nätverk som kör olika routing-protokoll. Ibland används samma namn för routrar mellan autonom system – AS.

En boundary router aggregerar route automatiskt exempelvis nätverksadresser 172.30.1.0, 172.30.2.0 och 172.30.3.0 representeras med adressen 172.30.0.0

Fördelar och nackdelar med automatisk route summering/aggregering

RIP-routrar uppdaterar varandras nätverksadresser helt automatiskt i ett classful nätverk. Ett sådant nätverk använder endast en och samma nätmask för alla delnät och därmed behövs inte inkludera nätmasken i uppdateringar. Detta minskar mängden av routing-information vilket resulterar att bandbredden används effektivare. Men när ett nätverk adresseras diskontinuerligt fungerar inte routing mellan de olika delnät.

Exempel 2

RIP har varit ett av de första routing-protokoll som har använts aktivt mellan ISP och deras kundnätverk. Men idag behöver kundnätverk inte skicka eller ta emot uppdateringar istället räcker att skicka datatrafiken till ISP router via en default route.

Bild 6: Default route – exempel 2

I exempel 2 router R2 skickar alla paket till route R3 via en default route. Routern R3 som är en ISP-router dirigerar nätverkstrafik till router R2 via en statisk route. Nu är de frågan hur dessa två statiska route hanteras i ett dynamiskt RIP-nätverk.

Konfigurationer

  • R2# configure terminal
  • R2(config)# router rip
  • route till nätverk 192.168.4.8 raderas från routing-tabellen
  • R2(config-router)# no network 192.168.4.8
  • R2(config-router)# exit
  • Default route som dirigerar allt nätverkstrafik till R3
  • R2(config)# ip route 0.0.0.0  0.0.0.0  serial 0/0/1
  • R2(config)# end
  • R2# show ip route
  • R3# configure terminal
  • RIP aktiveras av
  • R3(config)# no router rip
  • En standard statisk route mot R2
  • R3(config)# ip route 172.30.0.0  255.255.252.0 serial 0/0/1
  • R3(config)# end
  • R3# show ip route
  • R2# configure terminal
  • R2(config)# router rip
  • Inkludera default route i RIP uppdateringar
  • R2(config-router)# default-information originate
  • R2(config-router)# end
  • Felsökning på hur RIP hanterar uppdateringar
  • R2# debug ip rip
  • R2# undebug all

R1 märker att route till 192.168.4.0/24 och 192.168.5.0/24 är inte längre tillgänglig.

Routrar R1 och R2 växlar routing information i uppdateringar där R2 inkluderar default route mot R3.

Propagera Default Route in RIPv1

För att tillhandahålla Internetanslutning till alla andra nätverk behöver statiska route inkluderas i uppdateringar. Du skulle kunna konfigurera på R1 en statisk default route mot R2 men en sådan konfiguration är inte lämplig i ett nätverk som troligen kommer att ändras ofta. Istället låter man att detta hanteras av en dynamisk routing-protokoll. I flera routing-protokoll kan du använda kommandot default-information originate för att statiska default route propageras till alla närliggande routrar. I RIP kan också användas kommandot redistribute static metric xx