RIP

Routing Information Protocol (RIP) är ett distansvektor routing-protokoll som inte används i moderna nätverk, men utmärk protokoll för studera hur dynamiska routing-protokoll fungerar. Med några kommando växlar routrar routing-information med varandra.

Studera en stund topologin nedan:

Bild 1: Dynamiskt routing-protokoll RIP

Routrar R1, R2 och R3 har egna direkt anslutna nätverk. Till en början fylls routing-tabellen endast med direkt anslutna nätverk därmed routrarnas routing-tabell innehåller följande:

  • R1 ser endast två nätverk: 192.168.1.0 och 192.168.2.0
  • R2 ser endast tre nätverk: 192.168.2.0, 192.168.3.0 och 192.168.4.0
  • R3 ser endast två nätverk: 192.168.4.0 och 192.168.5.0

För att routrarna ska växla information med varandra aktiveras RIP på varje router med kommandot router rip i den globala konfigurationsläget. Därefter anges de direkt anslutna nätverk med kommando network.

Konfigurationer

  • Router> enable
  • Router# configure terminal
  • Router(config)# hostname R1
  • R1(config)# enable secret enpass
  • R1(config)# no ip lookup-domain
  • R1(config)# line console 0
  • R1(config-line)# password conpass
  • R1(config-line)# login
  • R1(config-line)# logging synchronous
  • R1(config-line)# exit
  • R1(config)# line vty 0 4
  • R1(config-line)# password vtypass
  • R1(config-line)# login
  • R1(config-line)# logging synchronous
  • R1(config-line)# exit
  • R1(config)# int g0/0
  • R1(config-if)# ip address 192.168.1.1 255.255.255.0
  • R1(config-if)# no shut
  • R1(config-if)# end
  • R1(config)# int s0/0/0
  • R1(config-if)# ip address 192.168.2.1 255.255.255.0
  • R1(config-if)# clock rate 250000
  • R1(config-if)# no shut
  • R1(config-if)# end
  • R1# show run
  • R1# show ip int br
  • R1# show ip route
  • Router> enable
  • Router# configure terminal
  • Router(config)# hostname R2
  • R2(config)# enable secret enpass
  • R2(config)# no ip lookup-domain
  • R2(config)# line console 0
  • R2(config-line)# password conpass
  • R2(config-line)# login
  • R2(config-line)# logging synchronous
  • R2(config-line)# exit
  • R2(config)# line vty 0 4
  • R2(config-line)# password vtypass
  • R2(config-line)# login
  • R2(config-line)# logging synchronous
  • R2(config-line)# exit
  • R2(config)# int g0/0
  • R2(config-if)# ip address 192.168.3.1 255.255.255.0
  • R2(config-if)# no shut
  • R2(config-if)# exit
  • R2(config)# int s0/0/0
  • R2(config-if)# ip address 192.168.2.2 255.255.255.0
  • R2(config-if)# no shut
  • R2(config-if)# exit
  • R2(config)# int s0/0/1
  • R2(config-if)# ip address 192.168.4.2 255.255.255.0
  • R2(config-if)# clock rate 250000
  • R2(config-if)# no shut
  • R2(config-if)# end
  • R2# show run
  • R2# show ip int br
  • R2# show ip route
  • Router> enable
  • Router# configure terminal
  • Router(config)# hostname R3
  • R3(config)# enable secret enpass
  • R3(config)# no ip lookup-domain
  • R3(config)# line console 0
  • R3(config-line)# password conpass
  • R3(config-line)# login
  • R3(config-line)# logging synchronous
  • R3(config-line)# exit
  • R3(config)# line vty 0 4
  • R3(config-line)# password vtypass
  • R3(config-line)# login
  • R3(config-line)# logging synchronous
  • R3(config-line)# exit
  • R3(config)# int g0/0
  • R3(config-if)# ip address 192.168.5.1 255.255.255.0
  • R3(config-if)# no shut
  • R3(config-if)# exit
  • R3(config)# int s0/0/1
  • R3(config-if)# ip address 192.168.4.1 255.255.255.0
  • R3(config-if)# no shut
  • R3(config-if)# end
  • R3# show run
  • R3# show ip int br
  • R3# show ip route
  • R1# conf t
  • R1(config)# router rip
  • R1(config-router)# network 192.168.1.0 
  • R1(config-router)# network 192.168.2.0
  • R1(config-router)# end
  • R1# show run
  • R1# show ip route
  • R2# conf t
  • R2(config)# router rip
  • R2(config-router)# network 192.168.2.0
  • R2(config-router)# network 192.168.3.0
  • R2(config-router)# network 192.168.4.0
  • R2(config-router)# end
  • R2# show run
  • R2# show ip route
  • R3# conf t
  • R3(config)# router rip
  • R3(config-router)# network 192.168.4.0
  • R3(config-router)# network 192.168.5.0
  • R3(config-router)# end
  • R3# show run
  • R3# show ip route

Här nedan routing-tabell från router R1. Lägg märke på route markerade med R (RIP). Nätverket 192.168.5.0 är två routrar ifrån R1 och den administrativa kostnaden är 120.

Router R2:

  • 192.168.1.0/24 [120/1] via 192.168.2.1, s0/0/0
  • 192.168.5.0/24 [120/1] via 192.168.4.1, s0/0/1

Router R3

  • 192.168.1.0/24 [120/2] via 192.168.4.2, s0/0/1
  • 192.168.2.0/24 [120/1] via 192.168.4.2, s0/0/1
  • 192.168.3.0/24 [120/1] via 192.168.4.2, s0/0/1

Som default aktiveras RIP version 1 när kommandot router rip exekveras. Här nedan illustreras kommandot show ip protocols som anger detaljerad information:

  1. RIP är igång
  2. R2 skickar RIP-uppdateringar varje 30 sekund
  3. R2 skickar version 1 RIP-uppdateringar, tar emot vilken version som helst.
  4. Automatiserad route aggregering är i gång
  5. R2 annonserar egna direkt nätverk: 192.168.2.0, 192.168.3.0 och 192.168.4.0
  6. R2 har fått via RIP-uppdateringar från 192.168.2.1 (R1) och 192.168.4.1 (R3)

RIP version 2 aktiveras med kommandot version 2. När RIPv2 aktiveras händer en del hos routrarna:

  • R2 tar inte längre emot RIPv1 uppdateringar, därmed inga route för avlägsna nätverk kommer att finnas i sin routing-tabell
  • R1 kommer inte längre att få uppdateringar för nätverket 192.168.5.0 eftersom R2 inte längre accepterar RIPv1 uppdateringar från R3.
  • R3 kommer inte längre att få uppdateringar för nätverket 192.168.1.0 eftersom R2 inte längre accepterar RIPv1 uppdateringar från R1.

Konfigurationer

  • R2(config)# router rip
  • R2(config-router)# version 2
  • R2(config-router)# end
  • R2# show ip protocols

Propagera en default route

Dynamiska routing-protokoll gör att routrar delar med varandra routing-information helt automatiskt. Men vad händer när det finns behov av statiska route i ett nätverk? Hanteringen av statiska route och dynamiska routing-protokoll demonstreras med topologin som visas nedan (samma som ovan men en router till):

Bild 2: Propagera en default statisk route

Konfigurationer

  • RIPv2 aktiveras av och automatisk aktiveras version 1
  • R2(config)# router rip
  • R2(config-router)# no version
  • R2(config-router)# end
  • R2# show ip route rip
  • Interface s0/0/1 adresseras och en default statisk route skapas
  • R1(config)# interface s0/0/1
  • R1(config-if)# ip address 209.165.200.226 255.255.255.252
  • R1(config-if)# no shut
  • R1(config-if)# exit
  • R1(config)# ip route 0.0.0.0  0.0.0.0  s0/0/1  209.165.200.225
  • En default statisk route propageras till alla RIP-routrar
  • R1(config)# router rip
  • R1(config-router)# default-information originate
  • R1(config-router)# end
  • R1# show ip route rip