RIPv2 – EIGRP

I denna laboration ska RIPv2 och EIGRP konfigureras i samma nätverk. Här nedan topologin som visar alla uppgifter som behövs. Routrarna är 1841 och switcharna 2960.

Bild 1: RIPv2 och EIGRP

Konfigurationer

Switch>ena
Switch#configure ter
Switch(config)#hostname S1

S1(config)#vlan 10
S1(config-vlan)#name HR
S1(config-vlan)#exit
S1(config)#vlan 20
S1(config-vlan)#name Sales
S1(config-vlan)#exit
S1(config)#vlan 30
S1(config-vlan)#name Production

S1(config)#int range fa0/1-5
S1(config-if-range)#switchport mode access
S1(config-if-range)#switchport access vlan 10

S1(config)#int range fa0/6-10
S1(config-if-range)#switchport mode access
S1(config-if-range)#switchport access vlan 20

S1(config)#int range fa0/11-15
S1(config-if-range)#switchport mode access
S1(config-if-range)#switchport access vlan 30

S1(config)#inter fa0/24
S1(config-if)#description Mot R1
S1(config-if)#switchport mode trunk

Router>enable
Router#config ter
Router(config)#hostname R1

R1(config)#int fa0/0
R1(config-if)#description Mot S1
R1(config-if)#no ip address
R1(config-if)#shutdown

R1(config)#int fa0/0.10
R1(config-subif)#encapsulation dot1q 10
R1(config-subif)#ip address 192.168.10.254 255.255.255.0
R1(config-subif)#no shutdown
R1(config-subif)#exit

R1(config)#int fa0/0.20
R1(config-subif)#encapsulation dot1q 20
R1(config-subif)#ip address 192.168.20.254 255.255.255.0
R1(config-subif)#no shutdown
R1(config-subif)#exit

R1(config)#int fa0/0.30
R1(config-subif)#encapsulation dot1q 30
R1(config-subif)#ip address 192.168.30.254 255.255.255.0
R1(config-subif)#no shutdown
R1(config-subif)#exit

R1(config)#int fa0/0
R1(config-if)#no shutdown

R1(config)#int s0/0/0
R1(config-if)#clock rate 64000
R1(config-if)#ip address 205.65.1.1 255.255.255.252
R1(config-if)#no shutdown

Switch>ena
Switch#configure ter
Switch(config)#hostname S3

S3(config)#vlan 40
S3(config-vlan)#name Engineering
S3(config-vlan)#exit
S3(config)#vlan 50
S3(config-vlan)#name Development
S3(config-vlan)#exit
S3(config)#vlan 60
S2(config-vlan)#name IT

S3(config)#inter range fa0/1-5
S3(config-if-range)#switchport mode access
S3(config-if-range)#switchport access vlan 40
S3(config-if-range)#exit

S3(config)#inter range fa0/6-10
S3(config-if-range)#switchport mode access
S3(config-if-range)#switchport access vlan 50
S3(config-if-range)#exit

S3(config)#inter range fa0/11-15
S3(config-if-range)#switchport mode access
S3(config-if-range)#switchport access vlan 60

S3(config)#inter fa0/24
S3(config-if)#description Mot R3
S3(config-if)#switchport mode trunk

Router>enable
Router#config ter
Router(config)#hostname R3

R3(config)#int fa0/0
R3(config-if)#description Mot S3
R3(config-if)#interface fa0/0
R3(config-if)#no ip address
R3(config-if)#shutdown

R3(config)#int fa0/0.40
R3(config-subif)#encapsulation dot1q 40
R3(config-subif)#ip address 172.16.41.254 255.255.255.0
R3(config-subif)#no shutdown
R3(config-subif)#exit

R3(config)#int fa0/0.50
R3(config-subif)#encapsulation dot1q 50
R3(config-subif)#ip address 172.16.42.254 255.255.255.0
R3(config-subif)#no shutdown
R3(config-subif)#exit

R3(config)#int fa0/0.60
R3(config-subif)#encapsulation dot1q 60
R3(config-subif)#ip address 172.16.43.254 255.255.255.0
R3(config-subif)#no shutdown
R3(config-subif)#exit

R3(config)#int fa0/0
R3(config-if)#no shutdown

R3(config)#int s0/0/1
R3(config-if)#clock rate 64000
R3(config-if)#description Mot R2
R3(config-if)#ip address 205.65.1.6 255.255.255.252
R3(config-if)#no shutdown

R1(config)#ip dhcp excluded-address 192.168.10.254
R1(config)#ip dhcp excluded-address 192.168.20.254
R1(config)#ip dhcp excluded-address 192.168.30.254

R1(config)#ip dhcp pool HR
R1(dhcp-config)#network 192.168.10.0 255.255.255.0
R1(dhcp-config)#default-router 192.168.10.254
R1(dhcp-config)#domain-name diginto.se

R1(config)#ip dhcp pool Sales
R1(dhcp-config)#network 192.168.20.0 255.255.255.0
R1(dhcp-config)#default-router 192.168.20.254
R1(dhcp-config)#domain-name diginto.se

R1(config)#ip dhcp pool Production
R1(dhcp-config)#network 192.168.30.0 255.255.255.0
R1(dhcp-config)#default-router 192.168.30.254
R1(dhcp-config)#domain-name diginto.se

R3(config)#ip dhcp excluded-address 172.16.41.254
R3(config)#ip dhcp excluded-address 172.16.42.254
R3(config)#ip dhcp excluded-address 172.16.43.254

R3(config)#ip dhcp pool Engineering
R3(dhcp-config)#network 172.16.41.0 255.255.255.0
R3(dhcp-config)#default-router 172.16.41.254
R3(dhcp-config)#domain-name diginto.se

R3(config)#ip dhcp pool Development
R3(dhcp-config)#network 172.16.42.0 255.255.255.0
R3(dhcp-config)#default-router 172.16.42.254
R3(dhcp-config)#domain-name diginto.se
R3(dhcp-config)#exit

R3(config)#ip dhcp pool IT
R3(dhcp-config)#network 172.16.43.0 255.255.255.0
R3(dhcp-config)#default-router 172.16.43.254
R3(dhcp-config)#domain-name diginto.se

Router>enable
Router#config ter
Router(config)#hostname R2

R2(config)#interface fa0/0
R2(config-if)#description Mot Webb server
R2(config-if)#ip address 8.8.8.1 255.255.255.0
R2(config-if)#no shutdown

R2(config)#interface s0/0/0
R2(config-if)#description Mot R1
R2(config-if)#ip address 205.65.1.2 255.255.255.252
R2(config-if)#no shutdown

R2(config)#interface s0/0/1
R2(config-if)#description Mot R3
R2(config-if)#ip address 205.65.1.5 255.255.255.252
R2(config-if)#no shutdown

R2(config)#interface fa0/1
R2(config-if)#description Mot R4
R2(config-if)#ip address 199.199.199.1 255.255.255.252
R2(config-if)#no shutdown

Router>enable
Router#config ter
Router(config)#hostname R4

R4(config)#interface s0/0/0
R4(config-if)#description Mot R5
R4(config-if)#ip address 10.10.10.2 255.255.255.252
R4(config-if)#no shutdown

R4(config)#interface s0/0/1
R4(config-if)#description Mot R6
R4(config-if)#ip address 10.10.10.5 255.255.255.252
R4(config-if)#no shutdown

R4(config)#interface fa0/1
R4(config-if)#description Mot R2
R4(config-if)#ip address 199.199.199.2 255.255.255.252
R4(config-if)#no shutdown

Switch>enable
Switch#config ter
Switch(config)#hostname S5

S5(config)#vlan 70
S5(config-vlan)#name Financial
S5(config-vlan)#exit
S5(config)#vlan 80
S5(config-vlan)#name Planning
S5(config-vlan)#exit
S5(config)#vlan 90
S5(config-vlan)#name Services

S5(config)#interface range fa0/1-5
S5(config-if-range)#switchport mode access
S5(config-if-range)#switchport access vlan 70
S5(config-if-range)#exit

S5(config)#interface range fa0/6-10
S5(config-if-range)#switchport mode access
S5(config-if-range)#switchport access vlan 80
S5(config-if-range)#exit

S5(config)#interface range fa0/11-15
S5(config-if-range)#switchport mode access
S5(config-if-range)#switchport access vlan 90

S5(config)#interface fa0/24
S5(config-if)#description Mot R5
S5(config-if)#switchport mode trunk

Router>enable
Router#config ter
Router(config)#hostname R5

R5(config-if)#interface fa0/0.70
R5(config-subif)#encapsulation dot1q 70
R5(config-subif)#ip address 100.100.70.254 255.255.255.0
R5(config-subif)#no shutdown
R5(config-subif)#exit

R5(config)#interface fa0/0.80
R5(config-subif)#encapsulation dot1q 80
R5(config-subif)#ip address 100.100.80.254 255.255.255.0
R5(config-subif)#no shutdown
R5(config-subif)#exit

R5(config)#interface fa0/0.90
R5(config-subif)#encapsulation dot1q 90
R5(config-subif)#ip address 100.100.90.254 255.255.255.0
R5(config-subif)#no shutdown
R5(config-subif)#exit

R5(config)#int fa0/0
R5(config-if)#no shutdown

R5(config)#int s0/0/0
R5(config-if)#description Mot R4
R5(config-if)#clock rate 64000
R5(config-if)#ip address 10.10.10.1 255.255.255.252
R5(config-if)#no shutdown

Switch>enable
Switch#config ter
Switch(config)#hostname S6

S6(config)#vlan 100
S6(config-vlan)#name Medical
S6(config-vlan)#exit
S6(config)#vlan 110
S6(config-vlan)#name Clinical
S6(config-vlan)#exit
S6(config)#vlan 120
S6(config-vlan)#name Therapy

S6(config)#interface range fa0/1-5
S6(config-if-range)#switchport mode access
S6(config-if-range)#switchport access vlan 100
S6(config-if-range)#exit

S6(config)#interface range fa0/6-10
S6(config-if-range)#switchport mode access
S6(config-if-range)#switchport access vlan 110
S6(config-if-range)#exit

S6(config)#interface range fa0/11-15
S6(config-if-range)#switchport mode access
S6(config-if-range)#switchport access vlan 120

S6(config)#interface fa0/24
S6(config-if)#description Mot R6
S6(config-if)#switchport mode trunk

Router>enable
Router#config ter
Router(config)#hostname R6

R6(config)#interface fa0/0
R6(config-if)#description Mot S6
R6(config-if)#no ip address
R6(config-if)#shutdown

R6(config)#interface fa0/0.100
R6(config-subif)#encapsulation dot1q 100
R6(config-subif)#ip address 200.200.100.254 255.255.255.0
R6(config-subif)#no shutdown
R6(config-subif)#exit

R6(config)#interface fa0/0.110
R6(config-subif)#encapsulation dot1q 110
R6(config-subif)#ip address 200.200.110.254 255.255.255.0
R6(config-subif)#no shutdown
R6(config-subif)#exit

R6(config)#interface fa0/0.120
R6(config-subif)#encapsulation dot1q 120
R6(config-subif)#ip address 200.200.120.254 255.255.255.0
R6(config-subif)#no shutdown
R6(config-subif)#exit

R6(config)#interface fa0/0
R6(config-if)#no shut
R6(config-if)#no shutdown

R6(config)#interface s0/0/1
R6(config-if)#description Mot R4
R6(config-if)#clock rate 64000
R6(config-if)#ip address 10.10.10.6 255.255.255.252
R6(config-if)#no shutdown

R5(config)#ip dhcp excluded-address 100.100.70.254
R5(config)#ip dhcp excluded-address 100.100.80.254
R5(config)#ip dhcp excluded-address 100.100.90.254

R5(config)#ip dhcp pool Financial
R5(dhcp-config)#network 100.100.70.0 255.255.255.0
R5(dhcp-config)#default-router 100.100.70.254
R5(dhcp-config)#domain-name diginto.se

R5(config)#ip dhcp pool Planning
R5(dhcp-config)#network 100.100.80.0 255.255.255.0
R5(dhcp-config)#default-router 100.100.80.254
R5(dhcp-config)#domain-name diginto.se

R5(config)#ip dhcp pool Services
R5(dhcp-config)#network 100.100.90.0 255.255.255.0
R5(dhcp-config)#default-router 100.100.90.254
R5(dhcp-config)#domain-name diginto.se

R6(config)#ip dhcp excluded-address 200.200.100.254
R6(config)#ip dhcp excluded-address 200.200.110.254
R6(config)#ip dhcp excluded-address 200.200.120.254

R6(config)#ip dhcp pool Medical
R6(dhcp-config)#network 200.200.100.0 255.255.255.0
R6(dhcp-config)#default-router 200.200.100.254
R6(dhcp-config)#domain-name diginto.se

R6(config)#ip dhcp pool Clinical
R6(dhcp-config)#network 200.200.110.0 255.255.255.0
R6(dhcp-config)#default-router 200.200.110.254
R6(dhcp-config)#domain-name diginto.se

R6(config)#ip dhcp pool Therapy
R6(dhcp-config)#network 200.200.120.0 255.255.255.0
R6(dhcp-config)#default-router 200.200.120.254
R6(dhcp-config)#domain-name diginto.se

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#no auto-summary
R1(config-router)#network 192.168.10.0
R1(config-router)#network 192.168.20.0
R1(config-router)#network 192.168.30.0
R1(config-router)#network 205.65.1.0

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#no auto-summary
R2(config-router)#network 8.8.8.0
R2(config-router)#network 205.65.1.0
R2(config-router)#network 205.65.1.4

R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#no auto-summary
R3(config-router)#network 205.65.1.4
R3(config-router)#network 172.16.41.0
R3(config-router)#network 172.16.42.0
R3(config-router)#network 172.16.43.0

 

R2(config)#router eigrp 1
R2(config-router)#no auto-summary
R2(config-router)#network 199.199.199.0 0.0.0.255

R2(config)#router rip
R2(config-router)#redistribute eigrp 1 metric 1

R2(config)#router eigrp 1
R2(config-router)#redistribute rip metric 512 100 255 1 1500

R4(config)#router eigrp 1
R4(config-router)#no auto-summary
R4(config-router)#network 10.10.10.0 0.0.0.3
R4(config-router)#network 10.10.10.4 0.0.0.3
R4(config-router)#network 199.199.199.0 0.0.0.255

R5(config)#router eigrp 1
R5(config-router)#no auto-summary
R5(config-router)#network 100.100.70.0 0.0.0.255
R5(config-router)#network 100.100.80.0 0.0.0.255
R5(config-router)#network 100.100.90.0 0.0.0.255
R5(config-router)#network 10.10.10.0 0.0.0.3

R6(config)#router eigrp 1
R6(config-router)#no auto-summary
R6(config-router)#network 10.10.10.4 0.0.0.3
R6(config-router)#network 200.200.100.0 0.0.0.255
R6(config-router)#network 200.200.110.0 0.0.0.255
R6(config-router)#network 200.200.120.0 0.0.0.255