Paket-konfigurationer

De olika EIGRP paket vill jag se i ett enkelt nätverk som det illustreras i bild 1 och jag vill se paketens beteende.

Jag lägger till två loopback interfaces, ett till R1 och ett till R2:

  • R1: Lo0 = 10.10.10.0 /24
  • R2: Lo0 = 11.11.11.0 /24

Konfigurationer

  • R1(config)# router eigrp 100
  • R1(config-router)# no auto-summary
  • R1(config-router)# network 10.10.10.0  0.0.0.255
  • R1(config-router)# network 192.168.1.0
  • R1(config-router)# exit
  • R2(config)# router eigrp 100
  • R2(config-router)# no auto-summary
  • R2(config-router)# network 11.11.11.0  0.0.0.255
  • R2(config-router)# network 192.168.1.0
  • R2(config-router)# exit

Observationer

  • router eigrp 100 startar upp EIGRP i instansen 100 (AS nummer 100)
  • AS numret måst matcha för båda routrar annars kan de inte vara grannar.
  • No auto-summary behövs eftersom EIGRP arbetar som default i classful routing vilket innebär att ingen EIGRP router inkluderar nätmasken i sina routing-uppdateringar. I exemplet kommer nätverken 10.10.10.0 /24 och 11.11.11.0 /24 att inkluderas i routing-uppdateringar som 10.0.0.0 och 11.0.0.0
  • kommandot network 10.10.10.0  0.0.0.255 betyder att att endast nätverk 10.10.10.0 gäller. Om istället hade använts kommandot network 10.10.10.0 omfattade detta alla nätverk i 10.0.0.0

Verifieringar

Direkt efter att man startar EIGRP inom en viss process eller inom ett AS-nummer börjar routrarna att bilda relationer (adjacency) med varandra via de EIGRP packeten Hello, Update, Request, Query, Replay, och Ack.

Router R1 har fått en ny granne med adressen 192.168.1.11

Router R2 har fått en ny granne med adressen 192.168.1.10

Bägge routrarna skickar också Hello-paket till sina respektive loopback interface, och båda ignorerar egna packet!

Att skicka Hello-paket till loopback interface är onödigt. Det kan åtgärdas så här:

  • R1(config)# router eigrp 100
  • R1(config-router)# passive-interface loopback 0
  • R1(config-router)# end
  • R2(config)# router eigrp 100
  • R2(config-router)# passive-interface loopback 0
  • R2(config-router)# end