Default Network

I denna laboration visar jag konfigurationen default route i EIGRP. En sådan väg, default route, inkluderas inte i EIGRP uppdateringar därmed sprids den inte ut till närliggande EIGRP routrar. Men det finns två konfigurationsmetoder som möjliggör att en default route sprids ut till alla EIGRP grannar:

  • network 0.0.0.0 0.0.0.0 <exit interface>
  • default network

Jag konfigurerar nätverkstopologin nedan med båda metoder:

Metod 1: statisk default route

  • R1(config)# router eigrp 15
  • R1(config-router)# no auto-summary
  • R1(config-router)# network 172.16.1.0
  • R2(config)# router eigrp 15
  • R2(config-router)# no auto-summary
  • R2(config-router)# network 172.16.1.0
  • R2(config-router)#exit
  • R2(config)# ip route 0.0.0.0 0.0.0.0 fa0/0
  • R2(config)# router eigrp 15
  • R2(config-router)# network 0.0.0.0
  • R2(config-router)# end
  • ISPF(config)# int fa0/1
  • ISPF(config-if)# ip address 172.16.2.1 255.255.255.0
  • ISPF(config-if)# no shut
  • ISPF(config-if)# int lo0
  • ISPF(config-if)# ip address 5.5.5.1 255.255.255.0
  • ISPF(config-if)# no shut
  • ISPF(config-if)# exit
  • ISPF(config)# ip route 172.16.1.0 255.255.255.0 172.16.2.2
  • ISPF(config)#end

Metod 2: ip default-network

Först raderar vi konfigurationen för default route på R2.

  • R2(config)# router eigrp 15
  • R2(config-router)# no network 0.0.0.0
  • R2(config-router)# exit
  • R2(config)# no ip route 0.0.0.0 0.0.0.0 fa0/0
  • R2(config)# router eigrp 15
  • R2(config-router)# network 172.16.2.0
  • R2(config-router)# exit
  • R2(config)# ip default-network 172.16.2.0
  • R2(config)# do show ip route
  • Även då 172.16.2.0 har konfigurerats som default-network kommer endast R1 att använda den, men inte R2. Konstig nog behövs här en default route
  • R2(config)# ip route 0.0.0.0 0.0.0.0 172.16.2.1