EIGRP konfiguration

Vi utforskar DUAL koncept och de tekniska begrepp i ett nätverk med fyra routrar. Dessa routrar ska konfigureras med EIGRP routing-protokollet.

Bild 1: Att konfigurera ett EIGRP nätverk

Alla routrar är av modellen 1841. All routrar har FastEthernet interface, men R1 och R2 har också Ethernet interface.

Konfigurationer

  • Interface konfigurationer
  • R1(config)# int Ethernet 0/0/0
  • R1(config-if)# description Mot R2
  • R1(config-if)#ip address 192.168.11.1  255.255.255.0
  • R1(config-if)# no shut
  • R1(config-if)# int fa0/0
  • R1(config-if)#description Mot R3
  • R1(config-if)# ip address 192.168.41.1  255.255.255.0
  • R1(config-if)# no shut
  • R1(config-if)# exit
  • EIGRP konfiguration
  • R1(config)# router eigrp 1
  • R1(config-router)# no auto-summary
  • R1(config-router)# network 192.168.11.0
  • R1(config-router)# network 192.168.41.0
  • Interface konfigurationer
  • R2(config)# int Ethernet 0/0/0
  • R2(config-if)#description Mot R1
  • R2(config-if)# ip address 192.168.11.2  255.255.255.0
  • R2(config-if)# no shut
  • R2(config-if)# int fa0/1
  • R2(config-if)# description Mot R4
  • R2(config-if)# ip address 192.168.21.2  255.255.255.0
  • R2(config-if)# no shut
  • R2(config-if)# exit
  • EIGRP konfiguration
  • R2(config)# router eigrp 1
  • R2(config-router)# no auto-summary
  • R2(config-router)# network 192.168.11.0
  • R2(config-router)# network 192.168.21.0
  • Interface konfigurationer
  • R3(config)# int fa0/0
  • R3(config-if)# description Mot R1
  • R3(config-if)# ip address 192.168.41.3  255.255.255.0
  • R3(config-if)# no shut
  • R3(config-if)# int fa0/1
  • R3(config-if)# description Mot R4
  • R3(config-if)# ip address 192.168.31.3  255.255.255.0
  • R3(config-if)# no shut
  • R3(config-if)# exit
  • EIGRP konfiguration
  • R3(config)# router eigrp 1
  • R3(config-router)# no auto-summary
  • R3(config-router)# network 192.168.31.0
  • R3(config-router)# network 192.168.41.0
  • Interface konfigurationer
  • R4(config)# int fa0/0
  • R4(config-if)# description Mot R2
  • R4(config-if)# ip address 192.168.21.4  255.255.255.0
  • R4(config-if)# no shut
  • R4(config-if)# int fa0/1
  • R4(config-if)# description Mot R3
  • R4(config-if)# ip address 192.168.31.4  255.255.255.0
  • R4(config-if)# no shut
  • R4(config-if)# int lo0
  • R4(config-if)# description Destination Network
  • R4(config-if)# ip address 5.5.5.1  255.255.255.0
  • R4(config-if)# exit
  • EIGRP konfiguration
  • R4(config)# router eigrp 1
  • R4(config-router)# no auto-summary
  • R4(config-router)# network 192.168.21.0
  • R4(config-router)# network 192.168.31.0
  • R4(config-router)# network 5.5.5.0

Kommandot show ip route eigrp visar routing-tabellen för EIGRP. Det framgår direkt bokstaven D som indikerar att vägen har kommit in via EIGRP uppdatering av en granne. Mer detaljer nedan:

D     5.5.5.0  [90/158720]  via  192.168.41.3,    00:21:48,      FastEthernet 0/0

  • D indikerar att EIGRP gäller.
  • 5.5.5.0 är nätverket som har konfigurerats på R4, looback interface
  • 90 är den administrativa distansen för EIGRP
  • 158720 ät värde för metric, som är den totala distansen eller Feasible distance
  • Via 192.168.41.3 är adressen till router R3, interface FastEthernet 0/0
  • Uppdateringen har tagits emot via interface FastEthernet 0/0

Nya relationer mellan närliggande routrar kan verifieras med show ip eigrp neighbors:

  • H (Handle): visar ordningen i vilken routrar har blivit grannar. Den första granne för värdet 0 och den andra för värdet 1 och så småningom.
  • Hold (sec): visar väntetiden innan en granne anses vara inte längre granne. Holdwon timer är som standard 15 sekunder.
  • SRTT (Smooth round-trip time): tiden i millisekunder som tar till att skicka en EIGRP packet till en granne och att grannen skickar tillbaka en kvittens.
  • RTO (Retransmission timeout): tiden i millisekunder som EIGRP kommer att vänta för ett svar från grannen
  • Q Cnt (Q count): antal EIGRP packet som väntar i en kö innan de skickas iväg. Ideell värde är noll.
  • Seq Num (Sequence number): Senaste uppdateringens serienummer som ska skickas eller tas emot.

Router R1 väljer vägen till destinationsnätverk 5.5.5.0/24 via router R3. Varför valde R1 länken med R3, och inte R2?

För att svara frågan måste vi utforska EIGRP topologi-tabellen med hjälp av kommandot: show ip eigrp topology

  • Första raden visar att det finns en successor och att det total avståndet från R1 till destinationen är 158720 (Feasible Distance)
  • P   5.5.5.0 /24, 1 successors, FD is 158720
  • Andra raden visar: via 192.168.41.3 (158720/156160), FastEthernet0/0/0
  • 158720 är den totala distansen (feasible distance)
  • 156160 är den rapporterade distansen (advertised distance)
  • Tredje raden visar: via 192.168.11.2 (412160/156160), ethernet0/0/0
  • 412160 är den totala distansen (feasible distance)
  • 156160 är den rapporterade distansen (advertised distance)

R1 valde länken med R3 därför att den rapporterade distansen (advertised distance, 156160) är mindre än den totala distansen (feasible distance, 158720). R3 är företrädare (successor) och R2 backup eller feasible successor. Det tillfredsställer villkoret, Feasible condition.

Alla paket från R1 till destinationsnätverk 5.5.5.0 dirigeras via R3 (successor). Men det kan också konfigureras nätverkstrafiken via routern R2 som är den Feasible Successor. Det görs genom att aktivera balansering, men först kontrollerar jag vad som visas i EIGRP topologin.

Routing-tabellen för router R1 visar endast en route till destinationsnätverket 5.5.5.0.

Router R2 (Feasible Successor) skulle användas om det totala avståndet (Feasible Distance) är mindre än den totala distansen som router R3 (Successor) har. Detta kan åstadkommas genom att multiplicera R3:s FD med en lämplig faktor, exempelvis 3.

158720 x 3 = 476160

412160 (feasible successor) är mindre än 476160 så att länken med R2 också kan användas, exekvera:

  • R1(config)# router eigrp 1
  • R1(config-router)# variance 3
  • R1# show ip route eigrp

Nu visar R1:s routing-tabellen två route till destinationsnätverket 5.5.5.0/24. Det innebär att paket till nätverk 5.5.5.0 skickas via R2 och R3. Lastbalansering har aktiverats.

Observationer

  • Nummer 1 är den AS numret som alla nätverk ingår i.
  • Kommandot no auto-summary exekveras så att EIGRP inte ställer router till classful routing.
  • Vid kommandoexekveringarna visas meddelande att en ny granne (neighbor) har anslutats till samma nätverk, närliggande routers IP adress och interfacet till vilket den nya grannen har associerats.

Varför valde R1 länken med R3, och inte R2, för att komma åt nätverket 5.5.5.0?

R1 valde länken med R3 därför att den rapporterade distansen (advertised distance, 156160) är mindre än den totala distansen (feasible distance, 158720). R3 är företrädare (successor) och R2 backup eller feasible successor. Det tillfredsställer villkoret, Feasible condition:

Advertised distance of feasible successor < Feasible distance of successor

Advertised Distance Feasible Distance Successor Feasible Successor
R1
R2 156160 412160 x
R3 156160 158720 x

 

Nu visar R1:s routing-tabellen två route till destinationsnätverket 5.5.5.0/24. Det innebär att paket till nätverk 5.5.5.0 skickas via R2 och R3. Lastbalansering har aktiverats. Vid misstänksamma fel kör följande kommando:

  • debug eigrp packets ? kommer att visa alla alternativ till felsökningar exempelvis Hello-pakett. Beroende på IOS version kan alternativen variera till exempel kommandot debug eigrp packets räcker i de flesta fall för att starta felsökningen. När debug startas ska du se till att du också stoppar det med kommandot no debug eigrp packets.

Passive-interface

Flera rader med information om Hello-packet visas för alla interfaces, inklusive för interfacet loopback som skickar ut också Hello-paket, men i onödan eftersom ingen nätverk till finns. Nu undrar jag om det är möjligt att annonsera ett nätverk utan att sända EIGRP-packet och ändå bygga upp relationer med närliggande routrar?

Jag skapar ett loopback interface på R2

  • R4(config)# router eigrp 1
  • R4(config-router)# passive-interface lo0

Nu kommer R4 att kunna fortsätta annonsera nätverket konfigurerat på loopback interface utan att få Hello-packet från själva interfacet. Men hur konfigurerar man flera interface förutom ett, exempelvis fa0/0? Behöver man exekvera kommandot passive-interface <interface> till varje interface?

Nej, det behövs inte. Istället kan man exekvera:

  • Router(config)# router eigrp 1
  • Router(config-router)# passive-interface default
  • Router(config-router)# no passive-interface fa0/0